How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Service Tech
Category: Car Electronics
Satisfied Customers: 10136
Experience:  8+ years of professional experience
13568747
Type Your Car Electronics Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have a Panasonic Va-70 in dash system fitted in a

Customer Question

I have a Panasonic Va-70 in dash system fitted in a Winnebago, all works fine until just turned on, began working on FM OK playing radio station when suddenly stopped working. Screen is now flashin welcome to Va 70 and no buttons seem to work. Appreciate any help you can give.
Terry
Submitted: 1 year ago.
Category: Car Electronics
Expert:  Russell H. replied 1 year ago.

Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

If it only shows 'Welcome to VA 70', then it has failed to initialize and has locked up. This sort of problem can be quite serious. But try unplugging the device from the power, and leaving it that way overnight. That might, possibly, clear up the problem if it was just a temporary 'glitch'.

First, if you would like to try an easier possible way, try holding down the Power button for at least 30 seconds, and see if it shuts off that way, making the need to unplug it somewhat less urgently troublesome.

(It's fair to warn you that unplugging it from the power may activate its anti-theft mechanism, and cause it to require a code if/when it starts up OK again.)