How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask ElectronicsPete Your Own Question
ElectronicsPete
ElectronicsPete, Electronic Engineer
Category: Car Electronics
Satisfied Customers: 16505
Experience:  Over 16 years of experience installing and repairing electronics.
30970729
Type Your Car Electronics Question Here...
ElectronicsPete is online now
A new question is answered every 9 seconds

I have a Blaupunkt Toronto 420 BT. Everything works, except

Customer Question

Hello,
I have a Blaupunkt Toronto 420 BT. Everything works, except that I cannot set the clock properly. Every time I reset the clock, within 1 minute it reverts back to the previous time. I tried the factory reset, but this didn't work; all the settings were reset to original except the clock, which stayed at the previous setting (did not revert to 00:00). I also unplugged the permanent 12V to the unit. This did not work either. Thanks.
Frank Cranmer
Submitted: 1 year ago.
Category: Car Electronics
Expert:  ElectronicsPete replied 1 year ago.

Hi Frank,

Try turning the RDS off.

If RDS is on, the stereo can receive a time signal for the region and will auto-update.

Customer: replied 1 year ago.
Hi Pete,Yeah, I tried that. RDS is OFF (also PTY is OFF) and the clock still reverts to UTC -4 (Atlantic Time). I am in EST (UTC -5). I looked thru the manual and don't see anything else that would do it. As I said, I already did the factory reset (everything reset except the time) and disconnected the permanent 12V (on reconnect of 12V the clock went to 00:00 but then reverted to the old time).I've a feeling it's a chip issue. The unit is only a month old, so I should be able to get a replacement if needed. But let me know if you have any other ideas. Thanks.Frank
Expert:  ElectronicsPete replied 1 year ago.

This isn't a function of the radio so I have no idea how or why it is doing it, unless there is a glitch within the software.

Since it is almost new, your best option would be to return it.

Pete.

Customer: replied 1 year ago.
I figured that as well. I will contact Blaupunkt and get a replacement.Thanks,Frank
Expert:  ElectronicsPete replied 1 year ago.

Please let me know if you need additional information and I'll be happy to help.

Don't forget to rate my help, it is how the site rewards me for my time...

Thanks,
Pete.

Related Car Electronics Questions