How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask ElectronicsPete Your Own Question
ElectronicsPete
ElectronicsPete, Electronic Engineer
Category: Car Electronics
Satisfied Customers: 16889
Experience:  Over 16 years of experience installing and repairing electronics.
30970729
Type Your Car Electronics Question Here...
ElectronicsPete is online now
A new question is answered every 9 seconds

I have a Kenwood DPX-300u head unit. About half the time I

Customer Question

I have a Kenwood DPX-300u head unit.
About half the time I get into the car and start it up, the unit is dead and will not turn on.
I have to push the little reset button to get it to turn on and, of course, it looses all the memorized settings which is really annoying.
I know the ground, battery and ignition connections are correct and working as it does work properly half the time.
And when the head unit is on, everything works perfectly.
I had a friend install the unit in his pickup and he had the exact same problem.
Submitted: 1 year ago.
Category: Car Electronics
Expert:  ElectronicsPete replied 1 year ago.

Hi there,

This sounds like a loose internal connection in the head unit or a loose or failing fuse that is causing an intermittent power connection.

Check the internal solder joints inside the head unit for any loose or bad connections.

Customer: replied 1 year ago.
That's exactly where I'm at.
I had another similar problem a while back with a Sony head. I actually found an open ground trace on the main board.
Just got this head back from the friend. Unfortunately, no visible problem on the bottom of the main board.
I guess I'll have to tear further into it.