How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Service Tech
Category: Car Electronics
Satisfied Customers: 9555
Experience:  8+ years of professional experience
13568747
Type Your Car Electronics Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have a new 2015 Camry hybrid with navigation. The nav. system

Customer Question

I have a new 2015 Camry hybrid with navigation. The nav. system is consistently about 200 feet off, with the car icon on the display map always showing the car to be that distance behind where the car actually is. Of course, this sets the entire nav. system off, mislocating intersections and turn directions. I took it to the dealer and they were able to do nothing. I have used bot integrated Nav. and dashboard add-on GPS systems for years and never experienced anything like this. Any ideas? Any suggestions on places to go for help?
Submitted: 1 year ago.
Category: Car Electronics
Expert:  Russell H. replied 1 year ago.
Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question. I think that the nav device, whatever it is (by maker and model number) is probably defective, and since your car is new and has a warranty, you should insist, with the dealership, on having it replaced by another nav system in working order.If the warranty from the dealership for the car does not cover the nav device, then the maker of the nav device should cover it instead. Without the maker and model # ***** cannot tell for sure what you could try in the way of adjustments or resets, but you should check the antenna connection for sure. One cure for this problem is, to have the software reloaded on the nav unit. Other people have had this sort of problem when either the software in the unit needed re-initializing, or the GPS antenna was loose or not well connected. (Check whether the GPS antenna's status is indicated on the screen somewhere... if it is not connected, then the indication may be altogether lacking.)

Related Car Electronics Questions