How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Cadillac
Satisfied Customers: 23591
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Cadillac Question Here...
Dan is online now
A new question is answered every 9 seconds

We did not complete the fix and I do not now want to chat on

Customer Question

Dan We did not complete the fix and I do not now want to chat on the phone Online is now fine .
Submitted: 2 months ago.
Category: Cadillac
Customer: replied 2 months ago.
please review this Account # 16383459 and Order ID# ***** and please do not charge me for the call which I received and it went to voice mail. In order to get back to this point I had to enter charge card again so please do not charge me for more than on chat. I still need resolution on this issue please
Jim
Expert:  Dan replied 2 months ago.

Hello, my name is ***** ***** I'm here to help get your problem solved.

Expert:  Dan replied 2 months ago.

Hello again, so what is going on now?

Customer: replied 2 months ago.
dan I see you charged me for the phone call and the online chat, I haven't received any information that is going to fix it or provide additional areas to review so I can get it fixed.
Expert:  Dan replied 2 months ago.

What is the problem you are having now? I don't control any if the billing related things but you can call 1800 number or email***@******.*** to take care of that. I can still answer any car related questions you have though.

Customer: replied 2 months ago.
Dan we never completed the initial chat you only said did i check the relay. I did,, not fixed
Expert:  Dan replied 2 months ago.

It looks like that was a different Dan but I'm willing to help. Check to see if blower motor control module has power on range wire. Let me know, thanks.

Customer: replied 2 months ago.
OK so lets start over. The blower motor will only function when it wants to. I have replaced the following
Blower motor, AC/Blower resister/control module, and today was the temperature control (i.e. on off degrees, defrost front rear etc). I checked the relay and the sun load sensors. All voltages are within tolerance. I also have cleaned the little blower next to the light switch that I believe senses the temperature. I am out of ideas
Expert:  Dan replied 2 months ago.

You probably have a wiring problem but during problem you need to monitor voltage on orange wire, ground on black wire, and signal on grey wire. Depending on which one is missing go from there. Let me know if you have questions or how test turns out, thanks.

Customer: replied 2 months ago.
Ok so the orange on the blower motor or on the control module. I only have 2 leads on my meter so one on orange and one on ground/black . I am unable to monitor signals.
Customer: replied 2 months ago.
what condition do you want the controls in high low with ac on or off
Expert:  Dan replied 2 months ago.

The blower should work in any condition. Check wiring at the control module, grey wire is a ground signal so you will see different amounts of voltage depending on what speed blower motor is on. So compare power, ground, and signal from when blower is working to when it isn't working so we know what wire is acting up.

Customer: replied 2 months ago.
Sorry we must have a disconnect the blower never is working I had 12 v on orange and like between 3-8v on gray.
Customer: replied 2 months ago.
I checked bot grounds passenger and driver sides under the thresholds (plastic cover getting in and out of car)
Expert:  Dan replied 2 months ago.

IF blower is never working that would point toward either blower or wiring between control module/blower motor. Check to see if blower motor has good power/ground if so but blower isn't working problem is either connector or blower motor. If no power or ground then check for power/ground coming out of control module on black/purple wires. If it has good power/ground at module but not blower motor this means wiring is problem. If no power/ground coming out of module but module has good power, ground, signal then new blower module is the problem. Let me know how it goes or if you have more questions, thanks.

Customer: replied 2 months ago.
ok so you are saying the new module is defective and I need to get another one? another Q why would it only work occasionally/ very occasionally. It turned on yesterday when I was on way to get part and then turned off. what else controls the blower
Customer: replied 2 months ago.
by the way both blower and wiring/ connector is new the blower control module is new and I have power to all. what else controls the blower
Expert:  Dan replied 2 months ago.

The controller in dash sends signal to blower motor control module then blower motor control module sends power/ground to the blower motor, nothing else is involved. IF signal, power, ground going to blower motor module are good but it is not putting out power/ground on purple/black wires that would mean new control module is defective. Keep me updated, thanks.

Customer: replied 2 months ago.
how do I get back to you I can do the additional checks in the AM since it is now dark here. What time works for tomorrow or do I need to pay again
Expert:  Dan replied 2 months ago.

You can reply to this answer at any time and you can wait until we get problem fixed before paying. I'll talk to you tomorrow, thanks again and have a good evening.

Customer: replied 2 months ago.
ok thanks Dan
Expert:  Dan replied 2 months ago.

No problem, I'll talk to you tomorrow.

Customer: replied 2 months ago.
OK I m back
Customer: replied 2 months ago.
On the orange and ground is 12 v
Purple to ground is between 8-10 v depending on the blower speed
Ground and orange 6-10 v
Black to ground 0v
Customer: replied 2 months ago.
OK I got a new blower control do I need to check anything else before i install the new one
Customer: replied 2 months ago.
ok it is fixed thank you
Expert:  Dan replied 2 months ago.

Good to hear it is fixed, thanks for update. Let me know if I can do anything else to help.

Customer: replied 2 months ago.
well it failed again i am wondering if the temp controller is killing the control module
Expert:  Dan replied 2 months ago.

No, but the blower motor could be doing it if pulling too many amps so I'd recommend replacing blower motor with control module. Let me know how it goes, thanks.

Customer: replied 2 months ago.
it is a new blower from same store
Expert:  Dan replied 2 months ago.

The new blower may be pulling too many amps. IF power/ground/signal are maintaining same readings then problem is definitely controller and only thing that would burn out controller is blower motor. or poor quality part.

Customer: replied 2 months ago.
OK so I changed the controller and I notices that on 1,2,or 3 it will run, when I put it up to 4 it runs for about 1 minute and when i put the speed to 5 it fails in 30 seconds. I noticed the squirrel cage is not as wide as the original and a little taller. SI is it possible the blower module is getting hot the thermaling off. maybe due to the cage not providing sufficient air to the module.
Expert:  Dan replied 2 months ago.

I don't think the cage would cause problem, it sounds more like a issue with the blower motor.

Customer: replied 2 months ago.
I have to go to work and may not have a chance to get back to you till Friday.
Expert:  Dan replied 2 months ago.

That is fine, let me know when you get a chance. Thanks.

Customer: replied 2 months ago.
Dan r u there
Customer: replied 2 months ago.
OK so here is where I am now with this issue
At the blower this is what I have
Black to Purple is 8.0vDC
Ground to black 0v dc
at the input to control module
Black to orange 12v dc
orange to grey the voltage varies 3vdc to 12vdc
Black to grey 0vdc
Customer: replied 2 months ago.
I put back in the original control module the blower fired up right away. I ran it for 5 min and the blower stopped. I am so frustrated with this what can be going on?
Customer: replied 2 months ago.
well if you ever come back i found a cluster of relays in the rear that are hot around 130 deg.
fnt ctsy
int lp
cigar
trunk rel
fuel tank rel
rr ctsy
I pulled them all and waiting for things to cool down before i try it again.