How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Cadillac
Satisfied Customers: 21418
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
Type Your Cadillac Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2002 bill with the 4.6 liter Northstar it won't

Customer Question

I have a 2002 bill with the 4.6 liter Northstar it won't start and just making a quiet click sound and the instrument panel is showing empty fuel. Is this fuel pump failure?
Submitted: 2 months ago.
Category: Cadillac
Customer: replied 2 months ago.
2000 deville
Expert:  Cary York replied 2 months ago.

Hi, I’m Cary and I’ll be helping you today.
Please understand that I can't smell, hear, or touch the vehicle either, so patience is appreciated. Before leaving the site make sure and leave me a rating. You can still reply to me as many times as needed, even after the rating..

Have you done anything yet to try and fix the problem?

Customer: replied 2 months ago.
All fuses good, relays have been switched around with no change. Digital fuel display shows empty. Tank is full. Display failure is usually associated with in tank fuel pump, we see failure. Wondering if it would also render starter inop? I have a picture of dash display
Expert:  Cary York replied 2 months ago.

Sorry for the delay. Just got off work. The fuel level display should not effect the starting system. Are we sure the battery and battery connections are good?

Customer: replied 2 months ago.
Keep in mind this is a 306,000 mile car. I'm pretty sure they are good, she is getting 12.4 volts on the battery. Delays are okay, I'm busy too.
Customer: replied 2 months ago.
I changed the starter at 170000, and fuel pump assembly at 160,000
Customer: replied 2 months ago.
My daughter says the connections to the battery itself are good and tight
Expert:  Cary York replied 2 months ago.

Sorry for the delay. I will have to opt out so another expect can help. Got to go to work.

Customer: replied 2 months ago.
Ok thanks
Expert:  sprinkles08 replied 2 months ago.

Hello and welcome to JustAnswer!

If the fuel gauge doesn't work at the starter doesn't engage then I would first suspect that the powertrain control module is not awake, either due to an internal failure or a loss of power or ground to it.

If fuse are good then the next step will be to see if the PCM communicates with a scan tool. Have you checked for communication?

Customer: replied 2 months ago.
I had the car towed to a mechanic in Corvallis, OR, and that is where they are with it, trying to make sure the connections and signals, ECM is good etc
Expert:  sprinkles08 replied 2 months ago.

Let me know if you need any more help!

Customer: replied 2 months ago.
Expert:  sprinkles08 replied 2 months ago.

You're welcome!