How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ryan Schott Your Own Question
Ryan Schott
Ryan Schott,
Category: Cadillac
Satisfied Customers: 82
Experience:  technician at Demarois Buick Gmc
Type Your Cadillac Question Here...
Ryan Schott is online now
A new question is answered every 9 seconds

Just did a front and rear brake service, machine rotors.

Customer Question

just did a front and rear brake service, machine rotors. next day the stability light came on and engine shut off. Says lost communication between PCM and abs module
JA: How old are the brakes? How many miles on the car?
Customer: New brakes, 169360
JA: What is the model of your '167360 Cadillac?
Customer: escalade 4wd
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: codes
JA: Anything else you think the mechanic should know?
Customer: c290, c0210, c1237, c0298, c0288, c0245, c0269
Submitted: 3 months ago.
Category: Cadillac
Expert:  Ryan Schott replied 3 months ago.

Can you send me the last 8 of your vin so i can look up the vehichle build.

Customer: replied 3 months ago.
Expert:  Ryan Schott replied 3 months ago.

Clear out the codes and see if c0245 resets, if it does the EBCM has failed and will have to be replaced, sometimes this is a fluke code but we need to see if it will clear and if it resets first.

Customer: replied 3 months ago.
I will do that, give me 10 minutes
Expert:  Ryan Schott replied 3 months ago.

ok. you may have to drive it a bit too duplicate when it threw the code the first time. I believe to run the test you need to be moving so you will have to do a short drive.

Customer: replied 3 months ago.
all we did was front and rear pad replacement, machine rotors. customer states never had this issue before. Any idea?
pushing pistons back in forcing fluid back through system?
Expert:  Ryan Schott replied 3 months ago.

That shouldn't have caused any of this as an issue, the codes are pretty much for YAW sensor and an internal module malfunction which is nothing you would have caused, its likely just coincidence or they are trying to get stuff for free sadly, if that 245 comes back though that is pretty much a death code for the EBCM but it would not be your guys fault.

Customer: replied 3 months ago.
driving now. tech says when the stabiltity light comes on the engine shuts off. The EBCM cause this?
Expert:  Ryan Schott replied 3 months ago.

shouldn't did it have any p codes in the ECM?

Customer: replied 3 months ago.
Expert:  Ryan Schott replied 3 months ago.

if it does shut off when the light comes on and 245 is present then try and run it w/ the ebcm disconnected, if the module is bad its possible it grounds the class 2 during a fault and kills it. but lets see what comes back first

Customer: replied 3 months ago.
drove vehicle. Went to hit brakes, stability active light came on, which put in limp mode. downshift into first, was able to get vehicle back to shop. No codes stored as of yet. no check engine light on, no abs light on, no brake warning light
Expert:  Ryan Schott replied 3 months ago.

the engine did not stall though?

Customer: replied 3 months ago.
didn't stall, be went into limp mode,
Expert:  Ryan Schott replied 3 months ago.

and you didn't get codes in any modules not even as history? were you slowing down to a stop or turning? It should have a code somewhere to make it go into reduced power usually a throttle body or communication code, are all of the modules responding when you talk to them

Customer: replied 3 months ago.
just hit the brakes, and vehicle went into to limp mode
Expert:  Ryan Schott replied 3 months ago.

was it the first time you hit them or did you drive for a bit?

Customer: replied 3 months ago.
no, was driving around in a nearby parking lot. Stopped 4-5 times. all good. Got the speed up, and hit the brakes moderately hard, then stability system light came on, and engine went into limp mode. No other lights or warnings came on.
Expert:  Ryan Schott replied 3 months ago.

If no codes will throw you might need to monitor the data of WSS while you get the traction light to throw and see if any signals are dipping out. Also under the carpet under the passenger sear is the YAW sensor see if you can read me the part # ***** of its bracket

Expert:  Ryan Schott replied 3 months ago.

if the number is ***** then replace it with pn 15220053. im trying to see if i can pull up the calibration data on that VIN there is an update for the EBCM as well

Expert:  Ryan Schott replied 3 months ago.

It won't let me pull up EBCM calibrations without being hooked up to it but there is an update for YAW sensor logic, but if you have the old PN they did have an internal issue which could be sending invalid data so the traction is trying to perform a control event when nothing is happening and that might be why the modules are getting confused.