How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask ggrote1 Your Own Question
ggrote1
ggrote1, ASE Certified Technician
Category: Cadillac
Satisfied Customers: 16506
Experience:  26 year GM master tech
19513769
Type Your Cadillac Question Here...
ggrote1 is online now
A new question is answered every 9 seconds

I have a 2004 Cadillac Escalade the left low beam headlight

Customer Question

I have a 2004 Cadillac Escalade the left low beam headlight is not working I replace the bulb it's still not working I checked the fuses we have power to the fuses in the fuse are good We have power to the head light ballast not sure what's going on I am a dumb white farmboy and need help
JA: Have you located the fuse box? Have you checked the circuit?
Customer: Yes I checked the circuit
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: I replace the headlight bulb and ballast
JA: Anything else you think the mechanic should know?
Customer: No I do not
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Cadillac Mechanic about your situation and then connect you two.
Submitted: 10 months ago.
Category: Cadillac
Expert:  ggrote1 replied 10 months ago.

all the other 3 headlights work fine ?

with the low beams ON do both fuses called LO HDLP LT and LO HDLP RT show 12 volts on both sides of both fuses testing them in place through the little openings in the tops of those 2 fuses ?

Customer: replied 10 months ago.
All three other headlamps are working I tested the fuses there's powerless 12 V of the fees
Customer: replied 10 months ago.
Did I lose you
Expert:  ggrote1 replied 10 months ago.

ok at the left low beam with the low beams set to on does the yellow wire terminal in the bulb connector show 12 volts at it ?

Customer: replied 10 months ago.
One moment please
Expert:  ggrote1 replied 10 months ago.

ok

Expert:  ggrote1 replied 10 months ago.

call me ?

or me call you if you give me your number

Expert:  ggrote1 replied 10 months ago.

if NO power at the yellow but the fuses showed 12 volts on both sides of them the issue is that yellow wire bad between the bulb and the fuse box OR internally in the fuse box there is a failure not letting the 12 volts from that fuse get out of the box through the yellow wire which it would need a new fuse box

Expert:  ggrote1 replied 10 months ago.

you can always get me back for FREE for any follow up any time with this question even after you rate me here at Justanswer

if you have any questions please ask as i do not get credit for my work until you rate me here at Justanswer