How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike S. Your Own Question
Mike S.
Mike S., ASE Certified Technician
Category: Cadillac
Satisfied Customers: 6703
Experience:  ASE certified
Type Your Cadillac Question Here...
Mike S. is online now
A new question is answered every 9 seconds

I have a 92 Allante, it starts, the gauge lights start

Customer Question

I have a 92 Allante, it starts, the gauge lights start flashing within the first 2 or 3 minutes, within about 10 minutes the engine dies, the spark and fuel pump shut down, let set an hour or 2 and it will start back up and do the same thing over again.
Submitted: 4 months ago.
Category: Cadillac
Expert:  Mike S. replied 4 months ago.

It sounds as though you are loosing electrical from the alternator/battery. If you have a voltmeter or 12 volt test light once the engine begins to falter, check for voltage along the circuit that is failing and I would start with the voltage to the main fuse box that houses the fuses for the fuel pump and the ignition. Something is probably loose.

Customer: replied 4 months ago.
It can't be just a loose wire can it because it wouldn't act the same way, in the same sequence and timing every time, such as let sit an hour or two, she'll start back up, again within the first couple minutes the gauge lights start flashing, within 10 minutes she dies again
Expert:  Mike S. replied 4 months ago.

The only other thing I can think of for right now is a security issue. Does this have a security system and if so is there any security lights on or flashing at any time?

Customer: replied 4 months ago.
ok hi I finally figured out how to get to you without paying again
Expert:  Mike S. replied 4 months ago.

Yes you did.

Customer: replied 4 months ago.
No there are no security lights or flashing at any time
Expert:  Mike S. replied 4 months ago.

Try a new ignition switch.

Expert:  Mike S. replied 4 months ago.

I take that back. I would try retrieving all the codes first, from all of the modules, which includes the body control module to see if anything is stored that may give a clue as to what is going on because it may just be a faulty body control module.

Expert:  Mike S. replied 4 months ago.

Did that answer your question? If so, kindly leave me a positive rating, so I get credit. If you have any more questions, go ahead and ask.