How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dave Nova Your Own Question
Dave Nova
Dave Nova, Cadillac Technician
Category: Cadillac
Satisfied Customers: 1522
Experience:  ASE Master Certification. GM World Class Certification
11042942
Type Your Cadillac Question Here...
Dave Nova is online now
A new question is answered every 9 seconds

The past month or so I've had problems with my 2008 Cadillac

Customer Question

the past month or so I've had problems with my 2008 Cadillac CTS. Every time I fill my tank, I have to pump the gas for it to start. 4 days ago I woke up and my car had no power. I jump started it and it ran for 2 days. Yesterday I replaced the battery only to wake up and jump start it again. This morning I had power to my radio and headlights but still had to jumpstart. Now I'm attempting to crank my car and there is no power at all. Do I have several issues going on here or is there one root cause of this headache? I should mention that I just put a brand new throttle body on.
Submitted: 6 months ago.
Category: Cadillac
Expert:  Ryan Schott replied 6 months ago.

Did you have a dealer reset the idle position when you replaced the throttle body, and do you have a meter to test the output of your charging system?

Customer: replied 6 months ago.
I reset the throttle sensor. I don't have a meter to test the output.
Expert:  Ryan Schott replied 6 months ago.

first I would verify the charging system output, you can grab a volt ohm meter at harbor freight for about 5$. These alternators will frequently fail if trying to charge a bad battery. Unlike old alternators these are really only designed for maintenance charging. Since it currently isnt starting however i would check your fuses since you have been jumping it, if you see no problems then try tapping on your ignition switch as contact sometimes fail.