How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Cadillac
Satisfied Customers: 35280
Experience:  34 year as an ASE Tech
7276279
Type Your Cadillac Question Here...
Ron is online now
A new question is answered every 9 seconds

Disconnected battery on my 2007 Escalade and now IPC is flashing

Customer Question

Disconnected battery on my 2007 Escalade and now IPC is flashing the dreaded blue needles.
JA: Thanks. Can you give me any more details about your issue?
Customer: Sure. Disconnected the battery for electrical work. 10 minutes. When I reconnected the battery, the display panel went dark except for the dial gauges flashing/ blinking blue. No other issues with the car. Tried disconnecting battery again and reconnecting after an hour. Still no luck.Checked all fuses related to the panel, the battery and related circuits. All are okay.
JA: OK got it. Last thing — Cadillac Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Cadillac
Expert:  Ron replied 1 year ago.
Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.You should be able to solve this problem by doing a reset. To do this disconnect both battery cables and hold them together for 5 minutes. After time is up, reconnect them and see if the cluster now resets.