How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt C. Your Own Question
Matt C.
Matt C., ASE Certified Technician
Category: Cadillac
Satisfied Customers: 41
Experience:  Master Automotive Technician
64275627
Type Your Cadillac Question Here...
Matt C. is online now
A new question is answered every 9 seconds

I have intermittent gh idle and also always slow to return

Customer Question

I have intermittent high idle and also always slow to return to idle. I have sprayed starter fluid all around the throttle body gaskets and around the boot between throttle body and throttle plate and found no change in rpm. I have also cleaned the throttle body and replaced both the TPS and IAC.
JA: Thanks. Can you give me any more details about your issue?
Customer: Uhh...
JA: OK got it. Last thing — Cadillac Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 8 months ago.
Category: Cadillac
Customer: replied 8 months ago.
This is a 2001 Olds Aurora with 4.0 Aurora (Northstar) V8
Customer: replied 8 months ago.
It also threw an IAC code one time but not again after cleared.
Expert:  tim's auto repair replied 8 months ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you

DID YOU REPLACE THE IAC?

Customer: replied 8 months ago.
Expert:  tim's auto repair replied 8 months ago.

does it eventually idle down to normal?

Expert:  tim's auto repair replied 8 months ago.

what codes do you get now?

Customer: replied 8 months ago.
Mostly. Every now and then, very intermittently, it will idle between 1500 and 2000 rpm and I have to ride the brakes to control the vehicle.
But it is always slow to return to idle. If I run it up to 3000+ rpm, in park, it will sit at 2500 rpm for 3 or 4 seconds before starting to drop down slowly to normal.
I've worked as an Electronic Tech and Mechanic all of my adult life, 31 years. I hate intermittent problems. The only consistent problem is slow return to idle.
Customer: replied 8 months ago.
I'm getting no codes since last week.
Customer: replied 8 months ago.
Here is data I saved today while driving. Don't know if this can help. Maybe I should do this while in park to catch the slow return to idle problem. I don't know what is normal so it's very difficult to assess this data.
Expert:  tim's auto repair replied 8 months ago.

stand by

Expert:  tim's auto repair replied 8 months ago.

sorry for the delay,internet trouble..

if you can not find a visable vacuum leak,,your problem may be the egr valve,,it may be sticking and not closing all the way,causing a major vacuum leak from the exhaust..

try removing and cleaning the valve on the egr.

thanks

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/3qojel1qi7syp2e/0316-olds-Locations%20View.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/3qojel1qi7syp2e/0316-olds-Locations%20View.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Customer: replied 8 months ago.
I will try to clean the egr on Sunday
Expert:  tim's auto repair replied 8 months ago.

ok

let me know how it gos

thanks

Customer: replied 8 months ago.
I removed the egr and opened and cleaned it. The problem continues. It's worse right after starting when the engine is still cold
Expert:  tim's auto repair replied 8 months ago.

ok

stand by,i will opt out.

someone will be right with you

thanks

Expert:  Matt C. replied 8 months ago.

Hello, did you perform the idle relearn after replacement of the IAC? Also, a common problem on this engine is the fuel pressure regulator leaking into the vacuum line

Customer: replied 8 months ago.
What is idle relearn. I disconnected the neg for 30 secs, thats it. Where is the fuel press reg located?
Expert:  Matt C. replied 8 months ago.

The fuel pressure regulator will be located towards the end of the fuel rail, you should see a vacuum line running to it. If you pull that hose off and see fuel in that line, or if you put a vacuum hand pump on it and see fuel come through then you have a bad fuel pressure regulator. An idle relearn typically requires a scan tool but sometimes will reset itself after about 10 minutes of highway driving.

Customer: replied 8 months ago.
Ok, I'll check the FPR tomorrow after work.
Expert:  Matt C. replied 8 months ago.

OK, let me know what you find. Also please don't forget to rate if I was successful in answering your question.

Customer: replied 8 months ago.
FPR checked out ok with vacuum hand pump. It's been several weeks I've been driving since I replaced IAC and TPS. Including lots of freeway driving. It seems that right now the high or sometimes surging idle problem is only occurring when it's cold although it still hangs around 2500 rpm for a couple seconds if I give it throttle in park so it's slow returning to idle
Expert:  Matt C. replied 8 months ago.

This is beginning to sound like you have a vacuum leak. I saw that you said you tried spraying starter fluid around some various places to see if there was a change in idle. The best thing to do is to have a smoke test performed as this is a lot more accurate.

Customer: replied 8 months ago.
Ok thanks
Expert:  Matt C. replied 8 months ago.

Your welcome. If you have been satisfied with my answers, please don't forget to rate your experience with me.

Related Cadillac Questions