How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tool Hut Your Own Question
Tool Hut
Tool Hut, ASE Certified Technician
Category: Cadillac
Satisfied Customers: 494
Experience:  Owner of a mobile diagnostics company assisting auto technicians with difficult vehicles
77480539
Type Your Cadillac Question Here...
Tool Hut is online now
A new question is answered every 9 seconds

I have a 2002 cad eldorado v-8 northstar engine. soon after

Customer Question

i have a 2002 cad eldorado v-8 northstar engine. soon after i start to drive my idle surges up and down i took the iac out and cleaned it with elect parts cleaner and this was no help. any ideas?
Submitted: 1 year ago.
Category: Cadillac
Expert:  Tool Hut replied 1 year ago.

Hi, My Name is***** have over 20 years experience repairing vehicles. I am a ASE Certified Master Auto Technician. I am confident we can resolve your problem together.Please remember I don't know your skill level. I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies to get to a satisfactory resolution.I also try to give all of the information you may need expecting a positive rating. If there is any reason I cannot get a positive rating please let me know.

I would try cleaning the mass air flow sensor with the same cleaner. Also I would clean the throttle blade with carb clean and a tooth brush. Unplug the throttle body before you open the blade to clean

Customer: replied 1 year ago.
I tried cleaning the MAF sensor I cleaned the throttle blade when I cleaned the IAC. This did not work after driving a few miles and car is warm the up and down idle starts. At stops the brakes have to be applied hard or just place the car in neutral then back in drive to proceed. The car has 70000 miles, for a 2002 that is low miles, plus I know the car because I bought it from a lady I work with and she bought it new. The car is immaculate inside and out. Everything works and it has all the options available. Consequently I do want to fix it. I only paid $2000 for it so sinking some money into repairs is OK. Enough background what should be done next? Do you think a complete tune up could do it? Let me know.
Expert:  Tool Hut replied 1 year ago.

With the hard brake pedal I would suspect you have a vacuum leak causing your problems. Or an EGR valve sticking open