How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Cadillac
Satisfied Customers: 33431
Experience:  34 year as an ASE Tech
7276279
Type Your Cadillac Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 91 cadillac seville 95,000 miles. 4.9. I got it

Customer Question

I have a 91 cadillac seville 95,000 miles. 4.9. I got it this way. It wont idle and barely starts runs ruff i have tested all injectors found one bad and i replaced it compresion is all above 150 lbs. Put new plugs and wires on it and cap and rotor. Still the same. Im gussing ecm but not sure. I unpluged it and pluged back in no change i have cleand all grounds no change..
Submitted: 1 year ago.
Category: Cadillac
Expert:  Ron replied 1 year ago.
Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
The problem you are describing could likely be a failing ECM but I would also make sure you have proper fuel pressure (32 to 38 PSI ) and I would also make sure there is no restriction in the exhaust system before you consider replacing the ECM.
Customer: replied 1 year ago.
Fuel pressure was 42 .44 lbs . Exhaust checked out good. I found a bad fuse and was able to get it to idle. But still have missfire on 3 and 8. Checked ig coil and it was bad so replaced and nothing changed . I replaced hall effect, pickup assembly, ignition module and put it back together and it burnt the new coil out again. I heard a bad connection in the red power wire could be the cuase but ran out of time last nite.
Customer: replied 1 year ago.
Ok
Expert:  Ron replied 1 year ago.

Okay so are you saying the problem is resolved?

Customer: replied 1 year ago.
Ok no car wont start now after rebuilding distributor. Coil still making a spark of the white wire bout to go double check everything i did
Customer: replied 1 year ago.
Ok
Expert:  Ron replied 1 year ago.

Okay recheck the spark as well as injector pulse , if you have both as well as proper fuel pressure the engine should start and run normally.