How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Cadillac
Satisfied Customers: 33431
Experience:  34 year as an ASE Tech
7276279
Type Your Cadillac Question Here...
Ron is online now
A new question is answered every 9 seconds

Cadillac Deville: I am working on a 94 Cadillac Deville. I

Customer Question

I am working on a 94 Cadillac Deville. I replace the plugs and wires cap and rotor and it started right up and I shut it off and now it won't start. It popped a couple times through the valve body and you have to floor it to try to start. I don't know where else to go. I have a scanner and I am not getting any codes. Next I may try a compression test. It was missing a little before I started. And now I have this problem. Any ideas?
Submitted: 1 year ago.
Category: Cadillac
Expert:  Ron replied 1 year ago.
Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
In order for the engine to start and run you need proper fuel pressure (32 to 38 PSI) , good spark to the spark plugs , injector pulse and good compression. I would start with checking each one of these things while its not starting and see which one you are lacking, post back with the results and we can work from there to get this issue resolved for you.
Customer: replied 1 year ago.
i just replaced the fuel pump and I have 42psi on the fuel rail. I pulled a couple plugs and they have great spark. I put in Bosch platinum plugs a week ago and just replaced the cap and rotor Wednesday and that is when the problem started. The only thing I have done yet is the compression test.
Customer: replied 1 year ago.
And the wires were replaced.
Expert:  Ron replied 1 year ago.
Okay double check to be sure you have compression as well as injector pulse. I would also double check the firing order to be sure the wires are in the correct order on the new cap.
Customer: replied 1 year ago.
I have checked the wires several times. I will run a compression check later this afternoon and get back with you.
Expert:  Ron replied 1 year ago.
Okay ,let me know and we can work from there.
Customer: replied 1 year ago.
Well I have it running now. It was way out of time. Extremely retarded for what reason I don't know. But now it doesn't idle steady. The RPM goes up and down at idle. Any ideas?
Expert:  Ron replied 1 year ago.
Was the distributor move or did you have to move it?
Customer: replied 1 year ago.
I had to move it. I used a jumper and put in diagnosing mode to set the timing. I jumped terminals A and B to set the timing.
Expert:  Ron replied 1 year ago.
If the distributor had not been moved and the timing was never touched and you had to reset it I have to wonder if the timing chain has jumped on you > the timing should not have moved unless it was set wrong or the chain has jumped.
Customer: replied 1 year ago.
Agreed. It runs great off idle now it just won't keep a steady idle.
Expert:  Ron replied 1 year ago.
I would check the timing chain for sure if you had to move the distributor.