How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, Master Technician
Category: Cadillac
Satisfied Customers: 17143
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL TECH.
1627031
Type Your Cadillac Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

Cadillac CTS V: I have 2010 cts v. It started with my (HOOD

Customer Question

I have 2010 cts v. It started with my (HOOD OPEN) then my battery dies overnight. I replaced battery thinking my battery was bad. The next morning the battery was died. And my emergency light and signal lights are not working too.
Submitted: 1 year ago.
Category: Cadillac
Expert:  FIXITMAN replied 1 year ago.
Hello, my name is***** for the question. If I am not online when you return please give me some time to get back to you. Did this all seem to occur at the same time? Is the car all stock?
Customer: replied 1 year ago.
The open hood light turned on first. The flashers I did not pay attention to it until later.and yes the car is all stock. No check engine light, and I had it checked for any codes. And no codes on it. When I jump it the voltage meter on the car 13.5 on idle and 14 + when revved up.
Customer: replied 1 year ago.
Are u there?
Expert:  FIXITMAN replied 1 year ago.
I am sorry for the delay in getting back with you. I had some connection issues with my computer. Did you still need help with this?
Customer: replied 1 year ago.
Yes I do.
Expert:  FIXITMAN replied 1 year ago.
Thank you. ***** am sorry for the delay. The most common cause of this is a bad connection at the rear fuse box. You need to locate the rear fuse box and remove the connector by loosening the center bolt. Loosen the connector and re-seat it. If the problem continues then you may have a bad connection at the ground cable or a failing body control module. Check the connector first and you should find the issue. If not then we can continue.
Customer: replied 1 year ago.
I will check it out in the morning. Thanks, ***** ***** let u know .
Expert:  FIXITMAN replied 1 year ago.
Thank you. I look forward to hearing back from you tomorrow.
Customer: replied 1 year ago.
The bolt on box was tight, but I unscrewed it and put it back on. And still the samething. No signal lights and open hood still on
Customer: replied 1 year ago.
So that did not fix my problem
Expert:  FIXITMAN replied 1 year ago.
Thanks. Lets check the ground that is in common to them. It is a little hard to get to but it is the ground located on the passenger side frame rail, towards the front of the vehicle near the radiator support. Make sure this ground is clean and tight. If it is then you more than likely have a body control module problem. You may want to check the connection at the body control module also.