How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Vladgmru Your Own Question
Vladgmru, Automotive Electrician
Category: Cadillac
Satisfied Customers: 2637
Experience:  I've been working with American made cars since 1992.
Type Your Cadillac Question Here...
Vladgmru is online now
A new question is answered every 9 seconds

Information center says engine is hot / AC off

Resolved Question:

Information center says engine is hot / AC off
Submitted: 6 years ago.
Category: Cadillac
Expert:  Vladgmru replied 6 years ago.
Hello and welcome to JustAnswer.
My name is Vladimir.
First of all, make sure your cooling fan comes on when the engine gets hot or when the AC is selected. If the cooling fan is OK then it is a good idea to have your AC condenser and engine radiator cleaned with a garden hose and compressed air. There is a space between the radiators where dirt and leaves tend to accumulate. Than prevents normal air flow through the radiators and your engine starts running a bit hot or even overheats.
Hope this helps.
Vladgmru and 5 other Cadillac Specialists are ready to help you
Customer: replied 6 years ago.
The car is not actually hot when the light comes on. It comes on immediatly after starting, the engine and radiator have been changed in the car.
Expert:  Vladgmru replied 6 years ago.
Engine hot - A/C OFF warning message, will be displayed if coolant temperature is above 243°F.
If you get this message immediately after starting cold engine, then there is a problem with the engine coolant temperature (ECT) sensor or its wiring.
You will need to remove the wiper motor module in order to gain access to the ECT sensor.
Customer: replied 6 years ago.
O k We changed the ect sensor and changed the plug to the etc sensorand are still getting the message the instant the vehicle is started.
Expert:  Vladgmru replied 6 years ago.
If the sensor and plug are new then it is time to check the wires between the sensor and Powertrain Control Module. You should werify that the wires are intact and not shorted to ground or power.if everything is OK then your PCM appears to be bad.
By the way, have you had your PCM scanned for trouble codes? If you have access to a scanner, what temperature appears on the scanner display?