How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag, Tech and Instructor
Category: Buick
Satisfied Customers: 6721
Experience:  Since 1975
Type Your Buick Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

I am working on a 2010 Buick Lucerne. I have no fuel pump

Customer Question

Hi my name is ***** ***** I am working on a 2010 Buick Lucerne. I have no fuel pump pressure I have tested the fuel pump and it is working the fuses are all good and the relay is working. There is no power between the relay and the wiring harness going into the pump.
JA: Is the power loss consistent, or does it fluctuate?
Customer: If I hardwire the fuel pump it runs at just under 60 pounds of pressure and the car runs fine
JA: Are you fixing your Lucerne yourself? What have you tried so far?
Customer: Yes, i have tested everything else out. I just don't know what to look for after the relay and between the fuel pump
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 1 month ago.
Category: Buick
Expert:  rpmdiag replied 1 month ago.

Hi, I'm Ron and I will be helping you today.
Stand by for a moment while I prepare your answer.

Expert:  rpmdiag replied 1 month ago.

Now you need to find the wiring break either in the harness or a bad connection somewhere in between there.

I have also seen rodents chew through the wiring harnesses quite often too. Not sure why, must be tasty for them, so check that first. Let me know if you need anything else.

Thanks, Ron

Customer: replied 1 month ago.
The customer drove the car cross his yard turn It off, went inside his house came back out and car would not start
Expert:  rpmdiag replied 1 month ago.

Okay, try this re-learn procedure just in case something weird happened in the system.

A scan tool would be my next suggestion to do some bidirectional tests on the pump.

Thanks again and please remember to rate me 5 stars and keep this link in case you need me again later on.


Customer: replied 1 month ago.
Pump works fine when it is hardwired. Scan tool shows no codes on dash. Power and ground cables from fuse box 2 fuel pump have continuity
Expert:  rpmdiag replied 1 month ago.

I'm not looking for codes, I'm looking for a loss of communication though the modules. This is right where this is leading.


Related Buick Questions