How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dave Nova Your Own Question
Dave Nova
Dave Nova, Buick Technician
Category: Buick
Satisfied Customers: 1808
Experience:  ASE Master Certification. GM World Class Certification
Type Your Buick Question Here...
Dave Nova is online now
A new question is answered every 9 seconds

Cruise isn't working, 1999 park ave ultra, Yes, tried

Customer Question

Cruise isn't working
JA: What is the model/year of your Buick?
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes, tried everything... Found I'm not getting power to the cruise control disengage pin at the cruise control module
JA: Have you checked the fuse? What size is your engine?
Customer: Yes 3.8
JA: Anything else you think the mechanic should know?
Customer: No
Submitted: 2 months ago.
Category: Buick
Expert:  Kevin Bourcier replied 2 months ago.

hello . I can assist you with this . Did it stop working all of a sudden or has it been intermittantly giving you an issue ?

Customer: replied 2 months ago.
Itermittantly... It quit before I purchased the car from a friend he owned it year only work intermittently for about 3 months
Expert:  Kevin Bourcier replied 2 months ago.

okay can you drive the car , be sure you are driving at least 40 MPH , turn the cruise switch on and before you push the SET button put your toe behind the brake pedal and " pull " the brake pedal towords you . hold it and then try setting vthe cruise on .

Customer: replied 2 months ago.
Tried that... I've used a multimeter to test all the pins at the cruise control module all work as they should expect pin h (cruise control signal-disengage) it has no power as it should until it reaches 30 mph then ground out
Expert:  Kevin Bourcier replied 2 months ago.

do you have steering wheel control or On The Turn signal arm ?

Customer: replied 2 months ago.
Turn signal arm
Expert:  Kevin Bourcier replied 2 months ago.

and tilt column of course

Customer: replied 2 months ago.
Expert:  Kevin Bourcier replied 2 months ago.

the only 2 common issues are the brake switch and the harness to the switch up the column . the harnesses will brake from the constant tilting up and down over time . I suspect either the cruise switch harness or the brake switch . you can check the 4 pin connector at the column under the dash with a DV meter to see if you are getting all the functions . ON , set , resume . Another cause on GM's but less likely is brake light bulbs out or lost ground circuits on the rear lighting harness at the tail light/brake light sockets .

Customer: replied 2 months ago.
I have tested all those connections they all work and all my brake lights are in working order... From what I understand from my research is at the control module 10 pin plug all pins test good except pin h (cruise control signal disengage) it's supposed to have 12v until speed reaches 30 mph then the pcm grounds the connection and should read 0v this then will allow you to engage the cruise control... When I test it reads 0v which tells me the pcm isn't powering it on so that connection would come from the pcm harness not steering column harness... I can't figure out where this wire comes from (it's dk grn) if it goes to the pcm how do I find it there?
Expert:  Kevin Bourcier replied 2 months ago.

let me check that

Customer: replied 2 months ago.
I have fixed it thanks
Expert:  Kevin Bourcier replied 2 months ago.

can you please leave me a positive feedback rating so I can get credited for assisting you .

Customer: replied 2 months ago.
Will do
Expert:  Kevin Bourcier replied 2 months ago.

thank you

Related Buick Questions