How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dave Nova Your Own Question
Dave Nova
Dave Nova, Buick Technician
Category: Buick
Satisfied Customers: 1808
Experience:  ASE Master Certification. GM World Class Certification
Type Your Buick Question Here...
Dave Nova is online now
A new question is answered every 9 seconds

It started, I backed up about ten feet, it beeped twice and

Customer Question

It started, I backed up about ten feet, it beeped twice and died. The motor cranks but will not restart.
JA: Have you checked the fuel supply? And are all the spark plugs working?
Customer: There is fuel in the tank, but I cannot tell if the fuel pump is coming on, or if there is another problem. Check engine light stays on on dash.
JA: What is the model/year of your Buick?
Customer: 2008
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: My husband is trying to get a trailer to take it to a local mechanic, not GM because that is quite a bit further away. I wanted input so I would know what direction we should be looking to resolve this. Trying to go on a trip today, so I would love for it to be fixed.
JA: Anything else you think the mechanic should know?
Customer: I have read that there are issues with the fuel pump relay switch. How do we determine if it needs the pump or the relay.
Submitted: 2 months ago.
Category: Buick
Expert:  Ron replied 2 months ago.

Hello, my name is ***** ***** I am a professional here at Justanswer. Thank you for your question and I will assist you with your concern.

If the check engine light is staying on then the first thing you need to do is to scan the computer system and see what the fault code and or codes are that should be setting. If you can get this done and post back with them I will help you get this resolved.