How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dave Nova Your Own Question
Dave Nova
Dave Nova, Buick Technician
Category: Buick
Satisfied Customers: 1808
Experience:  ASE Master Certification. GM World Class Certification
Type Your Buick Question Here...
Dave Nova is online now
A new question is answered every 9 seconds

I have problem with vehicle speed sensor I think changed it

Customer Question

I have problem with vehicle speed sensor I think changed it out with new and same problem persist
JA: Does the sensor have a wire-wrapped magnet? If so, have you checked it with an ohmmeter?
Customer: i don't know if it had wire wrap but i know it has magnet i tested the ohms it had 1900
JA: What is the model/year of your Buick?
Customer: 2002 century 3.1
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: replacing vss
Submitted: 3 months ago.
Category: Buick
Expert:  Reggie Whiddon replied 3 months ago.

good evening and thanks for the question, do you have a code for this sensor or is your speedometer not working? Did you carefully check the connector for the vss making sure the terminals were good and tight if they are spread open even in the slightest you will have a problem

Related Buick Questions