How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Andrew Martin Your Own Question
Andrew Martin
Andrew Martin,
Category: Buick
Satisfied Customers: 233
Experience:  Technician at Wile Hyundai
92331225
Type Your Buick Question Here...
Andrew Martin is online now
A new question is answered every 9 seconds

Buick riviera: I have a 1991 buick Riviera with an ac delco

Customer Question

I have a 1991 buick Riviera with an ac delco radio that has the right front speakers inop. I have ohmed them out, swapped them with the left front side and the speakers are not the problem. I am showing 5 plus volts on all the positive speaker leads to the front and rear speakers. I even purchased the same radio from a junk yard and have the same right side speakers inop. Spent way to much time on this minor problem. What am I missing other then maybe both ac delco radios have the same right front channel inop due to defective capacitors?
Submitted: 7 months ago.
Category: Buick
Expert:  Andrew Martin replied 7 months ago.
Check the wiring in the door jamb? I just had a newer buick the other day with a left speaker inop and the wiring in the door jamb was broken.
Customer: replied 7 months ago.
I will do that as soon as I get back to the car in about 30 plus minutes but I checked the ohms and volts at the speakers both main and sub and and the connector which is under the glove compartment and the values are the same. This in theory would cover anything in between but I will check
Expert:  Andrew Martin replied 7 months ago.
Alright
Customer: replied 7 months ago.
Ok I had checked ea of the four positive and negative wires that lead to the speakers in the door jam and to the left / right of door jam visually as well as digital meter and all look and read normal. So now I am looking to the left of the electrical connector under the dash by the passenger side. It's getting dark I will have to continue tommorow
Expert:  Andrew Martin replied 7 months ago.
Ok, if the wiring from the speaker to that connector is good it probably is the radio.
Customer: replied 7 months ago.
That's is why I mentioned it in the original question about swapping it out with another head unit in the first place. Seems odd both units would have the same problem
Expert:  Andrew Martin replied 7 months ago.
It does seem odd. Have you considered running new wires?
Customer: replied 7 months ago.
I have but it would be easier to run 2 jumpers from the head unit.
Expert:  Andrew Martin replied 7 months ago.
Yes it would be.
Customer: replied 7 months ago.
Well it appears that it is the the right front capacitor that is bad on both radios as stated in my original question What are the chances. Nothing else to to do other than solder in a capacitor in one of the radio heads. You did try to help find an alternative so I would like pay something for your effort
Customer: replied 7 months ago.
I still have the problem and it clearly is what I suspected in my original question although odd. Anyhow you tried to help and were courteous so I would like to pay something for your efforts what would be fair?
Expert:  Andrew Martin replied 7 months ago.
All you have to do is rate me positively, don't worry about tipping at all. Thank you!