How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Buick Technician
Category: Buick
Satisfied Customers: 44418
Experience:  16 years of experience
2499435
Type Your Buick Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

Buick tech only I have a 2012 lacrosse with front accident,

Customer Question

Buick tech only I have a 2012 lacrosse with front accident, the valve cover for the tranny was broken also the housing of the valve connector body connector is broken , But I manged to hook up the harness plug to the transmission . car now starts , but
doesn't get into revers not shift past 3 nd gear. my question is, do I have wire harness issue or the valve body itself may be impacted from the accident or have derby from the broken valve cover. tranny has no codes, but I retrived the following codes from
codes since this ignition cycle p2724 p2723 p2715 p2714 p2535 p0816 p0815 p0797 p0796 p0777 p0776 p0756 p0752 p0751 p0742 p0741 p0711
Submitted: 1 year ago.
Category: Buick
Expert:  Chris (aka- Moose) replied 1 year ago.

Check pins 1-10-13-18 at the transmission connector. Its very possible these powers and grounds are messed up and causing all these transmission codes that you have. Below is a wire diagram.

https://dl.dropboxusercontent.com/u/90220402/12buick.pdf

You want a excellent 5 star answer & I would like to be rated the same for providing it. Consider I don't know your skill level & I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies. Try your best to respond with good detail so I can do the same. I normally log in at 3pm and work late. A rating is required. Your rating me, what I type. I am not an employee of this website, nor have control over the fees or the time it took to get a response. If you rate negative or not at all you still paid, but I get nothing. I want you pleased with me and my efforts, so let me know if your experience here has come up short.

Thanks Chris

Customer: replied 1 year ago.
I checked the 12 v anDC the ground terminals as u mentioned and they are ok
But I did a mistake in my questions there was no codes with the tcm. All the codes that I listed they are tests to run that didn't ran so please ignore these code but I noticed one think when I tried to actuate solinoid valve one and two ad u can see in the attached picture the command is enabled but the valve status is offThis us foe both shift solinoid valves 1 &2
Expert:  Chris (aka- Moose) replied 1 year ago.

So even when attempting to drive it now with these issues no codes are being set?

Customer: replied 1 year ago.
no codes even when driving
Expert:  Chris (aka- Moose) replied 1 year ago.

Will your scan tool allow for monitoring the transmission range sensor/park neutral switch to see if its detecting the correct gear position you have selected?

Customer: replied 1 year ago.
let me check , but i think it is working correct since when I put in drive it shifts 1st , 2nd and 3rd
but I will double check
Expert:  Chris (aka- Moose) replied 1 year ago.

Thanks

Customer: replied 1 year ago.
scanner shows that the computer detects the correct position of the shift lever
Expert:  Chris (aka- Moose) replied 1 year ago.

The only thing I know left to do is pick some or one of the codes and do the diagnostic steps to resolve it and see how many codes that resolves. Will that help?

Customer: replied 1 year ago.
there is no codes ,
the codes I listed is the nion run test please ignore them
Expert:  Chris (aka- Moose) replied 1 year ago.

Sorry but I have nothing more to offer, would you like to try another tech