How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask DriverDave Your Own Question
DriverDave
DriverDave, ASE Certified Technician
Category: Buick
Satisfied Customers: 88
Experience:  29 Years Experience, Engine Performance, Driveability Expert and Advanced Level Smog Diagnosis
16810581
Type Your Buick Question Here...
DriverDave is online now
A new question is answered every 9 seconds

1995 BUICK: CEL..BOOST..EVAP SOLINOID NO SHORTED..ECM

Customer Question

HI: I HAVE PROBLEM WITH 1995 BUICK RIV 3.8 SUPERCHARGED CEL ON CODES PO1640 QUAD DRIVER 1 FAULT,PO131 HO2S HIGH VOLTAGE & PO171 FUEL TRIM LEAN?? CLEAR CODES ROAD TEST THREE TIMES PO1640 RESET IN MEMORY BUT NOT IN CURRENT CODES W/CEL ON BUT NO PO131 OR PO171 . TEST ALL THREE SOLINOIDS BOOST, EVAP PURGE & TCC OK: FOUND EVAP SOLINOID ACTIVATED ALL THE TIME AT IDLE GROUND ACTIVATED FROM COMPUTOR CK/ WIRE FROM COMPUTOR TO EVAP SOLINOID NO SHORTED TO GROUND.REPLACE ECM ROAD TEST ALL THREE CODES RESET, PO1640 NOT IN CURRENT IT IN HISTORY PO131 & PO171 IN IN CURRENT & HISTORY . ONE FUNNIE THING QUAD 1 SHOWS FAULT ON SCANNED AT IDLE IN REVERCE SHIFT IN TO NETURAL OR DRIVE AND SHOWED NO FAULT. FUEL PRESSURE OK NO VACUUME LEAKS & O2 RESPONDS RICH TO LEAN OK??
Submitted: 7 years ago.
Category: Buick
Expert:  DriverDave replied 7 years ago.

DRUDDY!,

 

Sorry to see no one seems to want to tackle this one but I will try to help.

 

P1640 is an internal PCM/ECM ram/rom error. By standard diagnostics this will lead to ECM replacement. If this is still coming back after replacement than you likely have a bad power or ground to the ECM

P0131 & P0171 indicate lean running engine on bank one.

 

As far as the quad driver, sometimes, even factory scanners like the Tech2 can missinterperate this and show a fault when there is none depending on the model.

 

You must figure out the P1640 first.

 

Hope this helps

Related Buick Questions