How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

I have a 2001 yamaha xlt 1200 I have a new battery good

Customer Question

I have a 2001 yamaha xlt 1200 I have a new battery good fuses but no power at the dash I hit the start button I have no display or no beeps tried resetting padlock code but after first step of disconnecting blue connector nothing happens warning light does not come on and nothing comes up after mode button is pressed I checked for power going into the dash and have 12 volts going in and nothing coming out I checked for continuity in start switch and it works fine except there is no power coming out of the dash to the switch I wanted to know if there is anything else to check because I know cluster is very expensive
Submitted: 1 month ago.
Category: Boat
Expert:  RSRBOB replied 1 month ago.

Hi and thank you for your question.

Since you are not getting the red light coming on when the blue connector is unplugged, it sounds like the multi funciton meter has failed. Two things I would suggest. See if you are getting battery voltage on the Red/Yellow wire coming OUT of the meter. (goes in red, comes out R/Y). One other test would be to make a jumper lead and ground the black wire coming out of the meter and see if it either powers up or the red light for the pad lock comes on with the blue connector unplugged. The only other easy test would be to check for continuity from the black wire on the harness side of the connector that has 4 wires, Green, Pink, Black and Red, to an engine ground. You should show continuity to ground.

Yamaha does not provide wiring diagrams for the internals of the multi function meter so if we have power in and nothing coming out, the meter has failed. If you have any other questions, feel free to ask.

Thanks,

Customer/p>
Customer: replied 1 month ago.
Thanks I thought the meter assembly was the culprit I will do those test tomorrow I already ordered a used meter assembly off of E-Bay I hope that solved the problem
Expert:  RSRBOB replied 1 month ago.

As long as the replacement meter is good, it should fix you up!

If you have any more questions, feel free to ask.

Thanks,

Customer/p>

Related Boat Questions