How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tan Your Own Question
Tan
Tan, MerCruiser Certified Technician
Category: Boat
Satisfied Customers: 10621
Experience:  40 yrs. experience with complete engine repairs both inboard/outboard and MerCruiser Certified Technician.
25721800
Type Your Boat Question Here...
Tan is online now
A new question is answered every 9 seconds

I have a mercuser 350 mag mpi bwi 1999. When I leave the

This answer was rated:

I have a mercuser 350 mag mpi bwi 1999. When I leave the boat for a week,It takes 5 to 10 minutes to start the engine.I think the fuel gos back into the gas tank. The people at the marina tell me I have a bad fuel pump but the engine runs fine when it starts. could I have a bad regulater?

Hello, I'm Tan. Welcome to JustAnswer. I'm reviewing your question and will reply momentarily.

There is a anti siphon valve at the tank that will allow fuel to sip[hon back into the tank when it sits. I would replace that valve and see if that remedies the issue. Once the engine starts doe it idle ok?

Customer: replied 1 month ago.
I have a mie 350 Mag MPI Bwi 1999 Merc Engine that takes About 5 to 10 minutes to start. After it,s going it seems to be fine. I am told it,s a bad fuel pump. I yhink the fuel is going back to the gas tank after a long time setting.could this be something ellse?

A bad anti siphon valve will cause this issue. Replace the anti siphon valve at the fuel supply line where it connects to the fuel tank.

Here is a anti siphon valve. Fuel should only flow one direction. http://forums.iboats.com/filedata/fetch?id=7040715&d=1400685903

Tan and other Boat Specialists are ready to help you
Customer: replied 1 month ago.
I think This could be the problem because my generator gets it fuel from the same fuel tank and I have trouble starting that to. Again once it,s running, It,s OK. Thanks. I,ll try this next year as the boat is on blocks for the winter

Ok let me know if you have questions. Thank you........Tan

Related Boat Questions