How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

I'm having a problem with my 2005 Verdrao 275s. One stalls

Customer Question

Hi I'm having a problem with my 2005 Verdrao 275s. One stalls out at idle. Was trying to find out why. Just had a service but did not change the spark plugs
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Marine Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so the Marine Mechanic can help you best.
Customer: Thank you
JA: Is there anything else the Marine Mechanic should be aware of?
Customer: No that's really all
Submitted: 1 month ago.
Category: Boat
Expert:  Joe replied 1 month ago.


Thank you for allowing me to assist you, my name is Joe and I will be happy to assist you with your concern today.

Idle in neutral or idle in gear?

If you increase speed will it prevent stalling?

You stated you just had service done, was this problem before this service or after?



Customer: replied 1 month ago.
Hi! It seems to be while it is in neutral. When I increase RPMs it stays on but then I have to ram it in gear which I don't like. There was a problem before. I thought it may have been the fuel filters but changed them and the oil and oil filters. I did not change the spark plugs however but intend to do that tomorrow. I am however using an octane booster as the fuel in the Bahamas is not very high obtain. My mechanic did tell me that my spark plugs had a yellow film on them when he checked them and no carbon build up. When I start the engine cold it idles fine. After it's been running a while the starboard engine just drops RPMs and dies. It's annoying when trying to pull into the dock with tidal currents. Could the octane boost be fouling out my plugs? Should I change them or clean them? Hope this helps
Customer: replied 1 month ago.
Just checking in to see if you had any word on this issue before I start work on the engine tomorrow morning.
Customer: replied 1 month ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.

Related Boat Questions