How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Charles Your Own Question
Charles
Charles, Marine Mechanic
Category: Boat
Satisfied Customers: 3343
Experience:  US Navy (Ret) Certified Mercury Marine Tech with over a decade of repair experience.
67216606
Type Your Boat Question Here...
Charles is online now
A new question is answered every 9 seconds

At first im sorry for my english, im from poland and i speek

Customer Question

Hello, at first im sorry for my english, im from poland and i speek english so and so, i have a problem with yamaha f 100 EFI (the same engine that mercury f100 EFI) it runs perfectly for some time 15-30 min and at high rpm it became to loos rpms
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Marine Mechanic I'm going to connect you with knows all the tricks and shortcuts. Is there anything else important you think the Marine Mechanic should know?
Customer: when i stop for a minute or two engine runs fine for another time and again in high rpm it is loosing on 4000 then 3000 then 1000 rpm
Submitted: 4 months ago.
Category: Boat
Customer: replied 4 months ago.
The engine will run up to 6,000-RPM and hold it for a twenty or thirty minutes. Then it's like it is starved for gas: the [engine speed] drops to 5500-RPM, then to 5000-RPM, 4000-RPM, 3500-RPM, until the engine dies if the throttle is left all the way open. If I throttle back, the engine doesn't die, it just goes back to idle speed. If I give it a few minutes I can again go all the way up to full speed and full RPM, and can hold it for another few minutes again. Problem keeps repeating faster.
Customer: replied 4 months ago.
both fuel pumps are new
Customer: replied 4 months ago.
primer bulb is new too
Expert:  Charles replied 4 months ago.

Hello, my name is***** will assist you.

Expert:  Charles replied 4 months ago.

The problem sounds like it is going to be a plugged filter or the fuel line running from the boat to the engine. When these lines begin to fail internally, they will block the fuel flow to the engine over time. Start by replacing all fuel lines from the boat fuel tank going to the engine, and replace the engine low pressure fuel filter.

Customer: replied 3 months ago.
filter and fuel line is new, what else i should check or replace
Expert:  Charles replied 3 months ago.

Your going to need to test the fuel pressure on the engine while it is running. Make sure that it is not dropping below 34 PSI. Also run a compression test on the engine. It should be over 180 PSI on all cylinders with the throttle opened.

Customer: replied 3 months ago.
While engine is running compression on fuel rail is ok until the engine speed drops at the same time compression drops.
Engine compression was tested and it is ok.
Expert:  Charles replied 3 months ago.

Engine compression cannot be tested on a running engine. This is done in the shop with all spark plugs removed, the throttle opened slightly and a compression test gauge screwed into one of the cylinders at a time. Crank the engine over until the gauge reaches its max reading for that cylinder. this should be done for all 4 cylinders. Below is what a normal test kit looks like

https://www.amazon.com/Engine-Compression-Tester/dp/B001Z0Y4A6

Customer: replied 3 months ago.
engine compression was tested as you wrote and it is ok, compression on fuel rail was tested on the water whith yamaha gauge compression test and it was as i wrote
Customer: replied 3 months ago.
fuel compression drops at the same time when rpms drops
Expert:  Charles replied 3 months ago.

Ok, when the fuel pressure, that is causing the engine RPM to drop as well. Feel the Vapor Sep Tank on the side of the engine to see if it is getting very warm where the fuel pump is located. If so, the pump is failing.

Customer: replied 3 months ago.
pump in water separator (high pressure) is new, low pressure pump is new too (i wrote it to you once)
Customer: replied 3 months ago.
fuel pressure regulator on vapor tank is new too
Expert:  Charles replied 3 months ago.

Run the engine on another fuel tank to see if the issue goes away.

Customer: replied 3 months ago.
when i was replacing high pressure fuel pump i also checked float in vapor tank
engine was running also on another fuel tank wiyh primer bulb, without primer bulb... the same issue
Expert:  Charles replied 3 months ago.

Do you recall what the compression numbers on the engine were?

Is the engine losing spark or the alarm sounding when this happens?

Customer: replied 3 months ago.
there is no alarm soundings, spark is excellent, i was testing it on the water with yamaha diagnostic computer and it said me nothing worse. Compression number 165-170 psi (Minimum compression pressure for that engine is 124.7 psi)
Expert:  Charles replied 3 months ago.

Does pumping the primer bulb over and over while the engine is starting to slow help or hurt the issue?

Has this engine been sitting for some time?

Customer: replied 3 months ago.
pumping primer bulb doesnt change a thing, engine hasnt been sitting for some time, what do you think about fuel injectors ? can they flood the engine ?
Expert:  Charles replied 3 months ago.

Yes, sticking injectors can flood the engine. you would also have fuel in the oil and fouled spark plugs.

Customer: replied 3 months ago.
Hello again I have checked my injectors and they are in perfect condition, what else can do such issue?
Expert:  Charles replied 3 months ago.

You wrote that the fuel pressure falls off as the RPM fall. You will need to test the fuel pressure regulator, and see if there is any debris inside the FSM.

Customer: replied 3 months ago.
I bought new pressure regulator and nothing has changed
Customer: replied 3 months ago.
what is FSM?
Expert:  Charles replied 3 months ago.

Sorry, on your engine it is the VST. this is where the electric fuel pump is located. Is that the one that you have replaced?

Customer: replied 3 months ago.
i have replaced both of them
Customer: replied 3 months ago.
Electric pump and diaphragm pump of course
Expert:  Charles replied 3 months ago.

Have you run the engine on a separate fuel source, including the fuel line from the tank to the engine?

Customer: replied 3 months ago.
separate tank, separate fuel line, separate primer bulb or no primer bulb, any configuration we could we did
Expert:  Charles replied 3 months ago.

Alarm ever activate?

Customer: replied 3 months ago.
there wasn't any alarm ever or check engine indicator on gauges
Expert:  Charles replied 3 months ago.

How is the water flow from the engine?

Customer: replied 3 months ago.
Water flow is very good on idle and on high rpm, when the issue starting water flow is still very good
Expert:  Charles replied 3 months ago.

There is a filter in the high pressure line, was that also replaced?

Customer: replied 3 months ago.
Filter on VST was replaced and filter before diaphragm pump was cleaned
Expert:  Charles replied 3 months ago.

What year is your engine, or the full model number. I will get the diagram for you.

Customer: replied 3 months ago.
I have full service manual and there is a lot of information but none of them helped me solve the problem , This is Yamaha 2006 F100DET, 6D9 L(###) ###-####
Customer: replied 3 months ago.
My engine is the same as Mercury 100 EFI and i have fuel filter like part 20
http://www.boats.net/parts/search/Merc2/Mercury/100%20EFI%20%284-STROKE%29/1B227000%20THRU%201B366822/Fuel%20Hose%20Routings/parts.html
Customer: replied 3 months ago.
all other parts are the same as in mercury
Expert:  Charles replied 3 months ago.

have you replaced it already?

Customer: replied 3 months ago.
i replaced it
I did also bypass filters and initial fuel pump and pumped manually using primer bulb while running
Customer: replied 3 months ago.
I ran out of ideas on how to fix the engine but do not want to give up so I decided to seek advice on your website
Expert:  Charles replied 3 months ago.

Ok, How is the voltage on the engine?

Customer: replied 3 months ago.
on gauges?
Customer: replied 3 months ago.
as i remember ther was about 14V
Customer: replied 3 months ago.
but now i cant check it out because it is 09.40 PM and im writing from home
Expert:  Charles replied 3 months ago.

If the voltage is falling when the engine is running, that will drop the power and can slow down the pump.

I have to run to a dr appt. back in about an hour.

Customer: replied 3 months ago.
only one thing is changing when engine drops the rpm - increases fuel injection time
Customer: replied 3 months ago.
what is dr. appt.?
Customer: replied 3 months ago.
I come back to talk tomorrow morning
Expert:  Charles replied 3 months ago.

do you have a computer hooked to the engine?

Customer: replied 3 months ago.
I had a computer hooked to the engine and the computer did not show any disturbing changes in the operation of the engine or errors
Expert:  Charles replied 3 months ago.

did the timing change as the engine warmed up or if throttle is applied?

Related Boat Questions