How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

I have an early 80s Volvo -- MD30A. The alternator went out,

Customer Question

Hi Jason,
I have an early 80s Volvo -- MD30A. The alternator went out, and I replaced it. After replacing, I have no voltage in the controls and I think there's a fuse issue or something related. I do have a reset fuse box, but not to my knowledge, no actual fuse.
Do you have any ideas?
Submitted: 4 months ago.
Category: Boat
Customer: replied 4 months ago.
I checked voltage across the F terminal and positive terminal on the new alternator, and I have voltage, as before.
My starter is hard to access, so I didn't check voltage there.
My engine controls have no voltage, but there is oil pressure, and the light for the glow plugs is on, but I think there's no power going to them when I turn the key to the right as I normally would.
And of course, no starter.
I read online that there might be two fuses, but my owners manual only shows the reset button, which they also call a fuse. I took that out and did an ohm test, and it is good.
Back to replacing the alternator—I forgot to switch the battery off, and I briefly touched the F lead to the positive and heard an alarm only during the brief time the leads contacted. My head was down in the bilge, but it may have been the engine controls alarm...I'm really not certain, though to my knowledge that's the only alarm onboard.
I could add more detail, but I'm not sure what all you might be thinking.
Expert:  Jason replied 4 months ago.

Hello my name is ***** ***** am I speaking with?

There is a 15 amp fuse (at least there Is supposed to be) inside the relay box on the side of the engine. Have you checked for power both into and out of that fuse?

Customer: replied 4 months ago.
Hi Jason,This is Zach, in Sitka, Alaska. Sorry I forgot to introduce myself.
My manual only shows an "Automatic fuse" and it suggests its 10Amps.
I couldn't find an actual fuse in the relay box. My relay box is on the front of the engine...unless I'm looking at the wrong thing.
I've attached a few pages from my owners manual.
Thanks a bunch.
Expert:  Jason replied 4 months ago.

Hi Zach. I do apologize, I had the wrong manual open. I was looking in the MD2030 manual, and not the MD30 manual. I do not have the correct manual for this engine, I will opt out and leave this open to the community. Good luck!

Customer: replied 4 months ago.
Thanks, Jason!

Related Boat Questions