How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tan Your Own Question
Tan
Tan, MerCruiser Certified Technician
Category: Boat
Satisfied Customers: 10662
Experience:  40 yrs. experience with complete engine repairs both inboard/outboard and MerCruiser Certified Technician.
25721800
Type Your Boat Question Here...
Tan is online now
A new question is answered every 9 seconds

Solenoid click no crank, 5.7L mercruiser engine, Battery

Customer Question

Slave solenoid click no crank
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Marine Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so the Marine Mechanic can help you best.
Customer: 5.7L mercruiser engine
JA: Is there anything else the Marine Mechanic should be aware of?
Customer: Battery good key switch tirns on fuel pump replace slave solenoid
Submitted: 7 months ago.
Category: Boat
Customer: replied 7 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 7 months ago.
battery good, when key is turned the electric fuel pump is working
Customer: replied 7 months ago.
I hear a click at the slave solenoid
I replaced the solenoid same click
Customer: replied 7 months ago.
tried to jump starter with new solenoid with the top two terminals large terminal not good either
Customer: replied 7 months ago.
tried to jump slave solenoid above comment
Customer: replied 7 months ago.
mercruiser 2001 engine 5.7L
Customer: replied 7 months ago.
dash gages volts gauge works tach gauge goes in reverse cabin light works power to the dash seems fine, trim power up down fine
Customer: replied 7 months ago.
the main plug with all the terminal pins is clean no issue
Customer: replied 7 months ago.
battery no issue
Customer: replied 7 months ago.
new slave solenoid should be no issue
Expert:  Tan replied 7 months ago.

Hello. My name is Tan.

Do you have a volt meter to do some voltage tests?

Customer: replied 7 months ago.
I do
Customer: replied 7 months ago.
make some suggestions cant test right now
Expert:  Tan replied 7 months ago.

Ok we need to test the voltage at the start solenoid on the starter with key in crank position. What is your voltage reading. If you have 9.5 volts then we need to test the voltage on the engine circuit breaker both terminals when key is in the crank position. What is your voltage reading?

Post back with those readings and we can continue.

Customer: replied 7 months ago.
make some suggestion to trouble shoot issue, test at solenoid and starter and its solenoid what would you recomend
Expert:  Tan replied 7 months ago.

We know the slave solenoid is good as you have replaced it. So it is possible we have a voltage issue or a starter issue.

Customer: replied 7 months ago.
ok thanks for your help!
Expert:  Tan replied 7 months ago.

Your welcome post back with findings.

Related Boat Questions