How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

I have a 2008 kawasaki ultra lx 20 hours on it. Used only in

Customer Question

I have a 2008 kawasaki ultra lx
20 hours on it. Used only in fresh water from day 1 .
Memorial day was used, ran perfect. Used today same batch of fuel then a new batch both had same issue. Runs alittle rough at idle. When you start to accelerate rpm dont go past 5k at full throttle , then all of a sudden revs go up to normal for a second then they drop back down . While the idle is stuck at 5 k it seems to run rough . Goes back and fourth from rough to smooth. I replaced spark plugs and situation is the same . I also replaced battery , no change ?
Submitted: 3 months ago.
Category: Boat
Expert:  Kenny O. replied 3 months ago.

Hi Bob my name is Kenny

Very low hours on this ski, how come, if you don't mind me asking ?

So I need to know if you were able to notice the boost gauge and how much boost it was producing at the high RPM ?

Also have you ever had this unit serviced ?


Customer: replied 3 months ago.
It is not super charged, it has 160 hp. Low hours due its at my vacation home used 4 -5 hours per season. I purchased in 2009 as a left over. It is meticulously maintained .
Customer: replied 3 months ago.
At idle rpm needle fluctuates a couple rpm , bounces a little. Last use 3 weeks ago , ran perfect. I am the only user. The impeller is clean as a wistle.
Expert:  Kenny O. replied 3 months ago.

OK thanks, ***** ***** read the model, if you have the HIN number let me have that, when the ski was running at full RPM do you remember what the max was ?

What about the fuel when the unit was sitting, was it stabilized ? so is there old fuel still in the tank, or was it ran out ?

I need the HIN as there were a few bulletins that might ally to your model/year


Customer: replied 3 months ago.
I assume u mean VIN#?
Customer: replied 3 months ago.
Fuel was run out , new fuel was pit in and problem continued.
vin# *****
Customer: replied 3 months ago.
Max rpm when running bad 6200
When it all of a sudden decides to run normal rpms go up to 7500
Expert:  Kenny O. replied 3 months ago.

HIN number (hull identification number) for boats and skis, I see your phone request, let me look up your hull number to see if it falls under one bulletin that I'm concerned about.


Customer: replied 3 months ago.
Expert:  Kenny O. replied 3 months ago.

There was an ignition issue on the year before and some applied to this year, this unit is not in the range that would requirement replacement, based on your location I'm assuming that its a salt water ski ?

Customer: replied 3 months ago.
The ski has never seen salt water , and has been flushed after every use even though it was used only in a fresh water lake . It has been serviced regularly
Expert:  Kenny O. replied 3 months ago.

When the engine drops the RPM, (by the way 7500 is about the normal RPM at wide open throttle) are you sure that its 6200 ? or could it be lower then that ?

Now when this happens it is it repetitive, or does it just do this ever so often ?

Customer: replied 3 months ago.
7500 when it all of a sudden goes normal then back to 6000 ish .
Normal WOT 54 mph
When its not running good it only hits 39 mph then all of a sudden it will jump up rpms and b normal then it will kick down again . Back and forth. However it never idles smooth,
Expert:  Kenny O. replied 3 months ago.

Sorry for the delay Bob, I was called out of town unexpectedly, when this happens do you know if SLO appears on the dash ?

Customer: replied 3 months ago.
Slo does not appear because i have the Fpo key in
Expert:  Kenny O. replied 3 months ago.

I understand that, what I believe is going on is an electrical issue with the wiring harness, there is circuitry from the meter to the ECU, its basically one wire that should have continuity from the meter to the ECU, if that wire looses continuity then it will interrupt the signal and give the ECU a false sense that the meter is telling it switch over to SLO mode, only thing puzzling to me is the RPM's should be a little lower.

Are you planning on working on this ? What is likely happening is a wire is backing out of one of the connectors, or you have a poor connection in one of the joint connectors, it has simple written all over it, but simple doesn't mean its going to be easy to find sometimes.

Can you check some of these connections Bob, I will help to point them out ?

Related Boat Questions