How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

I have a 2007 Evinrude 115 hp outboard motor that has been

Customer Question

I have a 2007 Evinrude 115 hp outboard motor that has been running fine. Last Saturday I started the engine and then noticed the kill plug attached to the key that is to be attached to the key starter was not in place, however, the engine was still starting. I then attached it and used the boat all day. Sunday I went out to start the boat and the engine would not turn over. I checked the battery and noticed it was some six years old so replaced it, I also checked the fuse in the engine and found it was ok. When I turn the key on I hear a clicking sound from the engine and the tack on my instruments spins. I feel it has to due with the kill connector, but cannot figure how or what may be causing it. Any thoughts?
Submitted: 3 months ago.
Category: Boat
Expert:  Charles replied 3 months ago.

Hello, my name is***** will assist you

Can I get the model number of your engine?

is your control box a Evinrude side mount?

Related Boat Questions