How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Noel Schembri Your Own Question
Noel Schembri
Noel Schembri, Marine Technician
Category: Boat
Satisfied Customers: 1951
Experience:  Advanced technical diploma
41498811
Type Your Boat Question Here...
Noel Schembri is online now
A new question is answered every 9 seconds

My 30 HP Nissan 4 stroke will run fine minute or two then at

Customer Question

My 30 HP Nissan 4 stroke will run fine for a minute or two then at high throttle it dogs down to low rpms and won't get back up to power. Only happens under a load, went through the carbs and rest of fuel system, everything looks good and so do the spark plugs
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Marine Mechanic I'm going to connect you with knows all the tricks and shortcuts. Is there anything else the Marine Mechanic should be aware of?
Customer: I tried new gas and every other simple solution but nothing has worked
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Marine Mechanic about your situation and then connect you two.
Submitted: 1 year ago.
Category: Boat
Expert:  Noel Schembri replied 1 year ago.

Hello my name is ***** ***** I will assist you. does the problem repeat itself after switching off the engine or is now always present?

Noel

Customer: replied 1 year ago.
When I let the engine rest a bit then run full throttle again it works fine for a couple minutes then dogs back down. Runs fine at idle and low throttle. Maybe something to do with temp sensor?
Expert:  Noel Schembri replied 1 year ago.

Try using a different fuel tank and line and see if the problem solves itself. Also make sure the vent of the tank is clear.

noel

Customer: replied 1 year ago.
No luck with that, I think the motor is getting hot and maybe the temp sensor is making it cut out but the water pump seems to be working just fine, plenty of pressure and water
Expert:  Noel Schembri replied 1 year ago.

Ok Check the thermostat then it should be located on the top of the cylinder head with 2 bolts. Make sure it is opening properly or to be sure it is not from there try it without a thermostat and see if the problem solves itself. As it may be that only part of the engine that is heating up.

Noel

Customer: replied 1 year ago.
Thermostat it was, got one ordered for tomorrow. Thank for your help
Expert:  Noel Schembri replied 1 year ago.

Great !! Glad you managed to solve the problem. If you require further assistance do not hesitate to contact me. Kindly rate my service.

Noel

Expert:  Noel Schembri replied 1 year ago.

If you do not require further assistance kindly rate my service.

Noel

Related Boat Questions