How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

No youre not : i rebuilt the carbs on a 1998 yamaha xl1200

Customer Question

no youre not
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Marine Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so the Marine Mechanic can help you best.
Customer: i rebuilt the carbs on a 1998 yamaha xl1200 and now have fuel and spark, which seems weak, but still will not start. It seems rich even though set to the manual specs. Im leaning electrical, but stumped at this point
JA: Is there anything else important you think the Marine Mechanic should know?
Customer: no[e
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Marine Mechanic about your situation and then connect you two.
Submitted: 4 months ago.
Category: Boat
Customer: replied 4 months ago.
i have used a rebuild kit, but did not replace any of the internal parts ie the high/low needles or seat or internal needle. The spark plugs are visibly wet from troubleshooting, so rich carb settings. Cylinder 1 and 2 seem to have better spark than 3
Customer: replied 4 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 4 months ago.
The pwc i am working on is a 1998 yamaha xl1200
Customer: replied 4 months ago.
what troubleshooting can be done to find the cause of the electrical issue?
Expert:  RSRBOB replied 4 months ago.

Hi and thank you for your question.

My suggestion is to determine if you do indeed have weak spark. That can be determined using a couple of different methods. One method is to use an automotive style inductive timing light and test each cylinder individually with the spark plugs installed in the head so you can see if they are firing under compression. Compression builds electrical resistance and it will show a weakness by not sparking under compression. The other would be to create a test spark plug by cutting the side electrode off of it and installing it in each spark plug cap one at a time and laying the plug on the cylinder head for a ground and checking for spark. The ignition system should jump a 6mm gap in atmospheric pressure, so that should give you a good idea as to the functionality of the ignition system.

It sounds like I may be coming in on the middle of this discussion, so if I may indulge you, I am curious as to why you rebuilt the carbs, and what you actually did if you didn't replace any internal components. Basically, I need to know what problems the ski was having, or what it was doing or not doing, that prompted you to rebuild the carbs.

Also, have you done a compression test on the engine lately?

I want to hold off for the time being on the richness issue. If there is a problem there, we can address that after we check the compression and spark.

Also, are you running the stock oil injection system?



Customer: replied 4 months ago.
I have been trying to figure this one out without knowledge of the history on the ski up until a couple days ago. The internals of the ski were rebuilt 4-5 years ago. After the rebuild they ran into an electrical issue and left it at that. Unfortunately, it was left with fuel in the system and was not getting fuel through the lines when I started. After the carb rebuild, without replacing any needles or seats, I am back to the original electrical issue. I tested the compression and all 3 ran within 1-2 psi of 125 which was in spec of the manual.The only reason i suspect a weak spark is because the tests have been inconsistent between tests, but one cylinder is consistently weaker. Could an issue with the cdi cause a weak spark?
Customer: replied 4 months ago.
I talked with the original owner and he mentioned, before the rebuild there were no issues with starting.
Expert:  RSRBOB replied 4 months ago.

It could, yes. However, I would suggest proceeding with a logical test sequence. The probability of the CDI box failing is very low, especially when compared to the components I suggested testing.

What exactly did you do in the carbs though? Typically on the pumper style carbs, unlike motorcycle carbs, the reason they don't flow fuel is the needle for the needle valve assembly gets stuck in the seat from not being used and prevents fuel flow. A motorcycle carb would clog jets from the fuel in the float bowl evaporating and leaving a residue behind. I really need very specific and detailed answers to all of my questions or this is going to take a very long time.


Customer: replied 4 months ago.
I cleaned the carb internals and replaced the gaskets, jets, and o-rings. After the rebuild i am getting fuel to the filter I'll try and find the inductive timing light to test tomorrow. Thanks for the advise
Expert:  RSRBOB replied 4 months ago.

YW. Let me know what you find.


Customer: replied 4 months ago.
I added oil block off when I did the carbs also
Customer: replied 4 months ago.
I tested the plugs while installed and am getting what seems weak spark. After testing I pull the plugs and are covered in fuel/oil mix. Also hearing a tiny pressure release somewhere around the carbs when i release the start button
Customer: replied 4 months ago.
It also tried a little ether spray and it started briefly but stayed at higher than idle revs.
Expert:  RSRBOB replied 4 months ago.

Thank you for the additional information.

If it starts and runs on ether, especially if it is idling higher than before, you have a fuel supply problem and not an ignition issue. I f it were only running on 2 cylinders it would not be idling too high, it would idle much lower than normal, if it idled at all. Was the ski winterized at some point where what you are seeing is fogging oil? The ether is essentially an alternate fuel supply so when you spray it, the ski runs. Ether won't mask an ignition issue so we need to focus on getting proper fuel delivery.

What ratio are you running for premix and what oil are you premixing?

Did you do anything to adjust the float arms or change the springs or needle valve assemblies?

The last thing I would suggest is double check the vacuum lines for the fuel pumps. Make sure each end of all 3 vacuum lines is connected to the engine cases above the reeds and to the backs of the carbs.

Do you know where the high and low speed screws are set right now?



Customer: replied 4 months ago.
The ether only started it once and then would not start again. The mix is 32:1 for the first tank The float needle or the basket were not replaced and neither were the idle screw springs, but changed o-rings on needles. I set the screws to the manual specs. The ski was never winterized and sat for years with gas in tank. I'm not sure which vac lines you are talking about. The pulse lines that connect to the block?
Customer: replied 4 months ago.
I poured the oil directly into the tank after fuel was added. Could this be an issue with a bad mix?
Expert:  RSRBOB replied 4 months ago.

I am not sure how you know you are at 32:1 if you poured oil into the gas tank. As an overall average, you should be running 50:1, although it is not a monumental difference between the 2 ratios.

I was not referring to the springs for the adjuster screws, I was referring to the spring for the float arm. I do not know what basket you are talking about. I apologize but I don't seem to be able to understand your answers to my questions. It feels like I am asking one thing very specifically and you are answering something else.

Yes, I was talking about the pulse lines. I was suggesting double checking each one of the 3 on both ends to make sure one had not come off. They can be quite tricky to get installed properly, so it is worth double checking, especially when you hear some weird sort of noise from that area when you let off the starter.

AS far as only starting 1x on ether, I suspect it fouled the plugs and that was why it would never re-start. Spark plugs cannot be cleaned to be restored to new condition. Once they are fouled, they are permanently damaged and need to be replaced.

I think at this point what you need to do is siphon all the gas out of the tank and start from scratch. Get a couple of 5 gallon gas cans regular 89 octane gas and Yamalube 2W marine 2 stroke oil. That is 2.56 ounces of oil per gallon of gas to yield a 50:1 ratio. By pouring the oil in the gas cans, you are able to shake the cans to ensure a thorough mix of the oil in the gas. Fill the tank from the gas cans.

I would suggest at this point spinning the engine over with the spark plugs out, but installed in the caps and grounded properly away from the open spark plug holes to try to pump out any gas and oil that might be sitting in the crankcase and causing the plugs to wet when attempting to start.

Replace the spark plugs and be sure to use resistor spark plugs and wide gap spark plugs. Non resistor plugs will produce RFI signals that will negatively affect the ignition circuit and cause running problems.

Check the pulse lines, and then try to start it. You should have to use full choke and no throttle at first, and if it doesn't light off fairly quickly, after the filter fills up of course, crack the throttle open ever so slightly to get it running. It will not run very long on the choke, so within seconds of it starting, be ready to shut the choke off completely.

Do you have a Yamaha Service manual or just the owners manual?

Did you happen to look at the catalyzer when you had the exhaust off to get to the carbs?

I will say I am impressed you were able to get the carbs off, that is no small feat on the XL1200's.

Give that a shot and let me know what you get. If we still are not getting fuel to the spark plugs, we will need to go back into the carbs and figure out why we don't have proper flow.



Customer: replied 4 months ago.
I pulled the tank and drained and cleaned the tank. Then poured 5 gallons of 89 and added the 40:1 ratio worth of oil. I changed the float arm spring with the one from the rebuild kit and when i said basket I misspoke and meant the seat. The pulse lines are secured. Why should the spark plugs remain in the plugs and grounded? I do have the manual. I am working on a 98 xl1200, the carbs aren't below the exhaust, thankfully. I apologize if I'm not explaining myself clearly, but this is my first time working on a carbed motor.
Expert:  RSRBOB replied 4 months ago.

Thank you for the additional information. I just lost about a half an hour's worth of response to you, so I am going to re-do it for you.

First, almost always, the needle seat assembly is a larger ID than the seat assembly that came with the carb from the factory. It came with a 1.2. Perhaps you can either find in your documentation or pull the new seats out and see what size they are. If they are any bigger than a 1.5, they are too big and will cause rich problems. The spring in the rebuild kits is also typically a lighter tension than the OEM spring as well. This too will cause a rich running condition. Now, if you happen to erroneously combine both a larger seat assembly with a lighter weight spring, you can drop the pop off pressure so much that fuel can be pushed past the needle and seat when the engine isn't running and cause it to flood out. This sounds like what you are describing. I do often recommend going up on the seat one size or dropping the spring pressure down one increment, to aid in cold start up, but to change them both at the same time is too much, and will create more problems than they solve. Either one individually is ok, but cumulatively you are asking for trouble. So the first thing we need to do is figure out what seat assembly you have in there, then figure out what spring you put in. The seat is stamped on the end that is installed into the carb body, so you will need to remove it. Hopefully you still have all the stock parts. The springs are color coded. They have gold - 115 gram rating, dull silver - 95 gram rating, black - 80 gram rating and shiny silver - 65 gram rating. It came with a gold spring from the factory, a 115g spring. You should have no problem with the dull silver spring and the 1.2 neelde seat assembly, or a 1.5 seat assembly with the 115g spring.

The intent behind pulling the plugs and grounding them was to allow you to crank the enigne over to blow out any fuel that may be in the bottom end of the crankcases (possibly from flooding due to carb settings mentioned previously). Also, if they have soaked in gas, the center insulator on the tip has become saturated and they will never run correctly, so they need to be replaced too.

So, questions still needing to be answered:

What brand of oil are you using for your premix?

Do you have a service manual or are you working out of the owner's manual?

If you have a service manual, is it an OEM Factory Yamaha or is it an aftermarket manual? The aftermarkets can be fine if they are well written. The OEM manual is the best but others can be perfectly fine too. It just depends on how they were written.

Why did you mix the oil at 40:1 when I suggested 50:1?

Take a look at the parts you put in your carbs and lets get them back to a known proven combination. Blow out the bottom end by spinning the engine over with the plugs out and grounded to the head, but away from the open spark plug holes. Keep cranking the engine until no liquid or vapor comes out the spark plug holes as you are cranking it. You can go a step further on this procedure by holding a rag over the open plug hole and creating a bit more crankcase pumping pressure and catching the fuel/vapor coming out of the cylinder. Once you get as much out as you can, install the new spark plugs, turn the gas on and try to start it as normal. It should start and run for you. Don't run it more than 15 seconds with out getting cooling water to the engine or it can overheat and seize a piston. You should have the adapter for the flush kit in with your took kit.

If you need more help, let me know,



Customer: replied 4 months ago.
I didn't change the spring or the seat, only the o-ring around the seat. I am using amsoil marine xlf. I have the service manual by Yamaha. I mixed the oil previous to your suggestion, but since added fuel to make a higher ratio.
Expert:  RSRBOB replied 4 months ago.

I don't know what to think.

Here is a copy and paste from your previous post: " I changed the float arm spring with the one from the rebuild kit and when i said basket I misspoke and meant the seat."

Now you didn't. I can only provide advice equal to the quality of information I am given.

I am going to have to opt out on this, too many partial answers, contradictions, etc.


Customer: replied 4 months ago.
I apologize for giving poor information, I think speaking on the phone would make things more accurate. Did not want to waste time. Thanks for all the help, you are very knowledgable.
Customer: replied 4 months ago.
I did mention priorly that I had not replaced any needles or seats. "After the carb rebuild, without replacing any needles or seats, I am back to the original electrical issue."

Related Boat Questions