How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

I have a albemarle boat with a 5.7 gi-e engine serial #3869258.

Customer Question

I have a albemarle boat with a 5.7 gi-e engine serial #3869258. The engine has always been hard to start, hot or cold. I've always had to fast idle or manually choke it to start it regardless of its hot or cold. Recently the engine has started a new issue of cranking up and running rich, sputtering, and a high pitch sucking noise coming from the throttle body and after ten seconds the engine idle flattens out and it runs perfect until you have to crank it up again. I unhooked the vacuum hose behind the throttle body going to the valve cover which I guess is a ac Delco pcv valve and no more hissing noise and it starts very easily without having to fast idle it. The rpms are Around 150 higher with the vacuum hose off and it still sputters for ten seconds before flattening out to a nice idle.
I have replaced the iac valve, fuel pressure regulator, last season the whole fuel pump was r laced, cleaned the throttle body, new spark plugs and distributor which all of this had had no improvement to the problem. Also have run it on a portable gas tank and still the same. The high fuel pressure was at 50 psi and seemed like it held there very well and the low side was 20 psi that went to 0 after the engine was cut off which wasn't sure if that was normal. Do you think the problem could be the fuel injectors or some kind of vacuum leak or getting to much fuel at start up?
Submitted: 6 months ago.
Category: Boat
Expert:  Jason replied 6 months ago.
Hello my name is ***** ***** am I speaking with? Have you run a compression test, or had it hooked up to a diagnostic scan tool yet?

Related Boat Questions