How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jason Your Own Question
Jason
Jason, Marine Mechanic
Category: Boat
Satisfied Customers: 14306
Experience:  Degree in Marine Technology. Gas and diesel marine mechanic.
44667847
Type Your Boat Question Here...
Jason is online now
A new question is answered every 9 seconds

JA: Thanks. Can you give me any more details

Customer Question

***** *****
JA: Thanks. Can you give me any more details about your issue?
Customer: Oil light
JA: OK got it. Last thing — Marine Mechanics generally expect a deposit of about $26 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 7 months ago.
Category: Boat
Customer: replied 7 months ago.
Just changed my oil a week ago took boat out and it ran fine all day then Friday I took it out and after ten minutes of running the oil light came on and stayed on motor went in to safe mode I turned it off then a hour later it started up just fine I let it run for a few more and light came back on
Expert:  Charles replied 7 months ago.
Hello, my name is ***** ***** I assist you with this?
Customer: replied 7 months ago.
Sure
Expert:  Charles replied 7 months ago.
Thanks, ***** ***** are you working with?
Customer: replied 7 months ago.
2007 df 175 suzuki
Expert:  Charles replied 7 months ago.
Have you checked the oil level in the sump lately?What oil did you put back into it?
Customer: replied 7 months ago.
Level is good and the Suzuki oil from the dealer
Expert:  Charles replied 7 months ago.
did the light have a pattern to and flashing at all or was it solid?Horn sound also?
Customer: replied 7 months ago.
Solid no horn and now when I reset the switch it flashes 3 times
Expert:  Charles replied 7 months ago.
How many hours would you say are on the engine?
Customer: replied 7 months ago.
Not sure probably around 1500
Expert:  Charles replied 7 months ago.
Did you reset the maintenance timer when you did the oil change?
Customer: replied 7 months ago.
It was not going off but yeah I reset it
Expert:  Charles replied 7 months ago.
Your code is 3 flashes...pause.... then 3 more?
Customer: replied 7 months ago.
Yea
Expert:  Charles replied 7 months ago.
Ok that is for the Neutral switch on the engine. Most of the time this is triggered actually by a voltage fault. Check your battery cables from the engine to the battery and make sure that there is no corrosion on them or the connection points on the battery. Even a loose connection can cause this error.
Customer: replied 7 months ago.
Yea
Customer: replied 7 months ago.
It can cause the oil light to come on and then make it go into safe mode ? I'll check but I'm not sure that is my problem
Expert:  Charles replied 7 months ago.
Yes it can. If you actually had low oil pressure, you would also have the horn going off. All of the research that I did on this issue points to the battery cables as the cause.
Customer: replied 7 months ago.
Hey Charles you there
Expert:  Charles replied 7 months ago.
Yes Im here.
Customer: replied 7 months ago.
Went threw all the wiring couldn't seem to find nothing wrong there
Expert:  Charles replied 7 months ago.
Checked over the battery cables from end to end?
Customer: replied 7 months ago.
Yes sir
Expert:  Charles replied 7 months ago.
Do you have a multimeter?
Customer: replied 7 months ago.
Yes
Expert:  Charles replied 7 months ago.
I need you to test that switch. It is located inside the control box. Can you do that?
Customer: replied 7 months ago.
What switch only switch in the control box is the tilt and trim
Expert:  Charles replied 7 months ago.
Part 7. the neutral safety switch.http://www.boats.net/parts/search/Suzuki/Outboard/2007/DF175/OPT:REMOTE%20CONTROL/parts.html
Customer: replied 7 months ago.
If it was that it would not even start
Expert:  Charles replied 7 months ago.
Ok, i will open your question back to the rest of the community here. Wish you the best of luck.
Customer: replied 7 months ago.
Ok
Expert:  Jason replied 7 months ago.
Hi Rob, my name is***** this something you still need help with?
Customer: replied 7 months ago.
Yes
Expert:  Jason replied 7 months ago.
The 3-3 code is for a neutral switch, also called a shift position sensor. But it is located on the engine shift linkage, not in the remote control. This tells the engine if it's in gear or in neutral. If the engine thinks it is in neutral it will not allow full power because Suzuki prohibits the engines from running to full throttle in neutral. I am attaching a file showing it's location and how to test it. See attachment. Let me know how you make out.
Customer: replied 7 months ago.
Yes idk how we got on this with the other guy but it runs fine until it runs for a few then the oil light comes on and it will go in to limp mode
Expert:  Jason replied 7 months ago.
The check engine light is flashing a 3 - 3 code, correct?
Customer: replied 7 months ago.
Yes the Rev light is the one that is
Customer: replied 7 months ago.
My issue is the oil light comes on after running for a few it comes on and stays on then will go in to limp mode
Expert:  Jason replied 7 months ago.
I read that you were getting a 3 - 3 code. Was the check engine light flashing that code?
Customer: replied 7 months ago.
No the Rev light
Expert:  Jason replied 7 months ago.
Ahh okay, that is the confusion. On these engines when there is an actual "Code" the check engine light will flash that code, not the other lights.If your oil light is coming on then the engine either really does have low oil pressure and the system is doing it's job, or the oil pressure sensor is bad and activating when it should not be. What we do in the shop is remove the oil pressure sensor and plumb in a mechanical oil pressure gauge in it's place, start the engine, and see if it has oil pressure or not. (It needs a minimum of 10 PSI at idle). If there is low oil pressure, we change the oil and filter and say a little prayer for the customer. If oil pressure remains low after the change the engine will need to be opened up and inspected, and more than likely a new oil pump installed. If oil pressure however does read good on the mechanical gauge, then the oil pressure sensor on the engine is bad and needs replacing. Does that make sense?
Customer: replied 7 months ago.
Yes thanks
Expert:  Jason replied 7 months ago.
You are very welcome. I think that should do it. But I work for tips so I do want to make sure you are happy with my service before you go. If you had a further question on the issue by all means feel free to ask. If not, Just in case you do not understand the way the website works (and some folks do not). You do have to put forth a positive rating in order for it to credit me for helping you. When ratings are not done, the website simply keeps your deposit and they will not credit me. The ratings box is located at the top of the screen. To rate, you must select the star you wish and also confirm it. Please let me know if you run into any problems or errors when trying to do it. If you do have a problem, or if you can not see the ratings box which is at the top of the screen. Please reply back "I rate Jason's service _______" and fill in the blank.Questions do not close out, so if you have to come back later on with follow up questions to the issue you still can even after doing a rating.Thank youJason
Customer: replied 7 months ago.
I was told if it was oil pressure the horn would sound
Expert:  Jason replied 7 months ago.
It's supposed to. Does the horn work?
Customer: replied 7 months ago.
Yes and I'm going to a suzuki dealer to put it on computer now I'll let you no what it is so if you have this ? Again
Expert:  Jason replied 7 months ago.
The oil pressure needs to be checked either way. It's possible there is some kind of ECM issue or a short in the harness causing a false alarm, but that would be rare. Let me know how you make out.
Expert:  Jason replied 7 months ago.
Hi Rob, just checking in. How are you making out?

Related Boat Questions