How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tan Your Own Question
Tan
Tan, MerCruiser Certified Technician
Category: Boat
Satisfied Customers: 10620
Experience:  40 yrs. experience with complete engine repairs both inboard/outboard and MerCruiser Certified Technician.
25721800
Type Your Boat Question Here...
Tan is online now
A new question is answered every 9 seconds

I have a 99 chapperal sunsets Volvo Penta 5.7 just put in brand

Customer Question

I have a 99 chapperal sunsets Volvo Penta 5.7 just put in brand new motor and having problems getting it going now . I would have sworn I hooked wires up same way they come off old motor when swapping on Accesories . When I turn key engine would not crank . I swapped the 2 small wires on left and right of solenoid and cranks and won't stop I assume I have wires wrong to starter or I messed up soloniod when I had then wrong first time . I have a yellow and a purple . I can't get yellow to show any power and purple is hot whole time key is on
Submitted: 7 months ago.
Category: Boat
Expert:  Jason replied 7 months ago.
Hello my name is ***** ***** am I speaking with? What is the model number on the original engine that was in the boat, that will tell me what wireing you have. Next, did you change any wiring at the key switch, or was that all left alone?
Customer: replied 7 months ago.
This has been a ongoing project sort of when I get time I work on it I pulled the engine out a while ago the both been sitting for two years put new engine in trying to get running now . I thought the keyswitch might've been bad so I replaced it and got same results . The old engine cover says 5.0 GL not sure where to find any other number you might want
Expert:  Jason replied 7 months ago.
What exactly is the problem with it. Is it not starting, or starting and not stopping?
Customer: replied 7 months ago.
When you turn the key to the first position the starter engages in stays running . When I first swapped the engine harness to the new engine and connected the wires to the starter I thought I had them the right way but would not turn over at all so I swapped the yelloow and purple wire on the solenoid then the engine would turn over as soon as you have the key to first turn but would not stop turning over
Expert:  Jason replied 7 months ago.
Is your yellow solid yellow, or yellow with a red stripe?
Customer: replied 7 months ago.
Purple wire has constant power the yellow wire does have a red stripe and I can't seem to when I turn the key get any power to it
Expert:  Jason replied 7 months ago.
The yellow/red is the start wire. Do you have 2 small posts on the starter solenoid?
Customer: replied 7 months ago.
Yes
Expert:  Jason replied 7 months ago.
The purple goes on the left post, the yellow/red goes on the right post. Is it wired like that now?
Customer: replied 7 months ago.
It was also a brand new starter along with motor on this install
Expert:  Jason replied 7 months ago.
The purple goes on the left post, the yellow/red goes on the right post. Is it wired like that now?
Customer: replied 7 months ago.
So right is agonist the engine left is outer one
Expert:  Jason replied 7 months ago.
correct. Is it wired that way right now?
Customer: replied 7 months ago.
I pulled the wires off and was testing power with them disconnected so let me reconnect them and see what happens . I thought it was very methodical and how I pulled the accesories and the harness from the old motor to apply to the new motor . And I did this outside the boat In my shop with the two engine side-by-side . I was thinking I did not even take the wires off of the alternator but now I'm contemplating if I switch the alternator wires the purple and white maybe
Expert:  Jason replied 7 months ago.
okay keep me posted
Customer: replied 7 months ago.
Ok when I have the yellow with red stripe on right and purple on left and turn key it does nothing . So maybe I have a wire swapped on alternator
Expert:  Jason replied 7 months ago.
If you turn the key to start are you getting voltage on the yellow/red at the starter?
Customer: replied 7 months ago.
No power to yellow/red wire
Expert:  Jason replied 7 months ago.
were you holding the key to start when measuring the voltage? (You need a helper for most testing)
Customer: replied 7 months ago.
I clamped to yellow/red post and put prob to negative in battery no powering key on or crank position
Expert:  Jason replied 7 months ago.
Go to the key switch next, is there any power out of the yellow/red at the key switch?
Customer: replied 7 months ago.
Yes when I Turn switch to start I get power at the yellow red
Expert:  Jason replied 7 months ago.
This new motor, did you carry over all of the electrical and harness from the old engine? Or did the new motor come with a new harness and electrical?
Customer: replied 7 months ago.
I swapped my harness onto the new engine
Expert:  Jason replied 7 months ago.
Do you know the full model number of the old engine? GL would be just a family of engines, but the full model number would have more letters after the GL
Customer: replied 7 months ago.
Not sure when the engine numbers are. Where the yellow red wire come to he engine and plug in I am not getting power there so tracing it from key switch under dash to see where power is being lost
Expert:  Jason replied 7 months ago.
Most Volvo's use a starter relay. If you go to your relay box, and put your fingers on top of the relays while a helper flips the key back and forth to start, can you feel any of the relays clicking?
Customer: replied 7 months ago.
Can't locate any starter relay . Looks like engine numbers were on side of power block thing that connects to heat riser and where my wire harness connects to engine . Can't make out those numbers . I temporarily bypassed the Killswitch tether to ensure that that wasn't cutting my power But thinking now that would be ignition power and not starter power but pulling at straws here
Expert:  Jason replied 7 months ago.
Without a model number or being in front of the engine myself I don't think i'm going to be able to solve this one. I will opt out and leave this open to the community, if one of the other guys wants to take a stab at it they will. The biggest issue is not having a proper model # *****
Expert:  Tan replied 7 months ago.
Hello. My name is ***** ***** this locate the yellow/red going from key switch to the control. Then out of the control will be another yellow/red check for voltage on that wire when key is in crank position. Do you have voltage. What we are testing is the neutral safety switch in the remote control.
Expert:  Tan replied 7 months ago.
Here is a diagram of your start circuit. The 5.0 and 5.7 are the same.
Customer: replied 7 months ago.
Problem was where the yellow/red wire goes to the shifter it was not connecting like it was in gear
Expert:  Tan replied 7 months ago.
That's great. Please don't forget to positively rate my help as that is the only way I get paid.Follow up questions are always welcome at no extra charge on this subject even after you have positively rated me. Thank you......Tan
Customer: replied 7 months ago.
I guess one of the things that should be checked when the boat won't start and there's no power to the starter wire at the starter that they check the neutral safety switch at the shifter
Expert:  Tan replied 7 months ago.
Correct that is why I posted that test first.

Related Boat Questions