How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

What could be wrong with my two 2005 waverunners. When is a

Customer Question

What could be wrong with my two 2005 waverunners. When is a VX 1100 sport and the other is an FX cruiser we are both do not display the miles per hour but they do display the check on water readings. In both cases the speedometer we'll under the hull spin freely
Submitted: 8 months ago.
Category: Boat
Expert:  RSRBOB replied 8 months ago.

Hi and thank you for your question.

It is quite curious that both wave runners have the same problem, no speedo display. You said they go through the check, which is encouraging, but do the other functions actually work after it goes through the check? Things such as the tachometer, fuel level gauge, hour meter, etc?

If the paddle wheels are spinning freely and you are still not getting any display while riding the skis, I would suggest looking for the triangular white plastic connector and see if it is unplugged or possibly corroded.

Let me know what you find with this and we can go from here if need be.

Thanks

RSRBOB

Customer: replied 8 months ago.
Where would I find the triangular white connector. Any chance you could give me some type of direction to find it
Expert:  RSRBOB replied 8 months ago.

Typically it is found on the left side of the craft just ahead of the engine compartment. You should see the main harness of wires there and it should be in that bunch. Alternatively, you can start at the leads coming out of the meter and trace them backwards to the white triangular connector. It should not be terribly difficult to find. You can try pulling the seat off and looking from inside the engine compartment forward or open the front hatch and pull the storage locker out and look back towards the engine.

RSRBOB

Customer: replied 8 months ago.
Ok thanks. If the wire and connector look good what are the next rule outs
Expert:  RSRBOB replied 8 months ago.

Powering up the hall effect sensors and testing the output.

Customer: replied 8 months ago.
What do you mean by powering up the "hall"
Expert:  RSRBOB replied 8 months ago.

Its a test for the speed sensor. I am still waiting for you to answer the other questions before we get into that. It is important that we proceed in a methodical order. Please refer to my first response and address those questions and inspections and let me know what you find. Truly, the hall effect failing is very low probability so I suspect it is something else.

RSRBOB

Customer: replied 8 months ago.
I will look at the triangular plug this weekend I am not at home at this time to answer your question
Expert:  RSRBOB replied 8 months ago.

Not a problem. I completely understand. I am going with the highest probability of failure first. Hall effect sensors just don't ever fail. Well, almost never. :)

Customer: replied 8 months ago.
OK I'm done for this question thank you I'll figure it out

Related Boat Questions