How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

How do I connect properly, the water outflow tube of the

Customer Question

how do I connect properly, the water outflow tube of the pump, to the receiving tube of the engine, there is a small connector which joins both of them but it is hard to set it in the right position and worst still make sure it was left in place and working when you do the final closing of the lower unit. Any comments on E tecs overheating..? I have two 250s 2013, and it is driving me insane
JA: Thanks. Can you give me any more details about your issue?
Customer: yes
JA: OK got it. Last thing — Marine Mechanics generally expect a deposit of about $26 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 8 months ago.
Category: Boat
Customer: replied 8 months ago.
My E tecs are 700 hours old,ocean driven, properly flushed after every use, good quality TCW3 oil, good non ethanol fuel, 150 hours impeller changes, changd the water pressure gadgets above the EMM just in case, thermostats chaanged twice, added high flow water screens in lower units, yet they overheat above 185 in 80 F. ocean temps whenever I go above 3800 rpms, This problem started when engines 400 running hours plus. I have read some reviews on etecs and see it is a pretty common problem. I wonder if you can help me out.
Expert:  Joe replied 8 months ago.

Hello,

Thank you for allowing me to assist you, my name is Joe and I will be happy to assist you with your concern today.

Do you have a picture of the connector you are referring to?

If not please provide the model number of the unit and exactly which part you are referring to.

Thanks,

Joe

Related Boat Questions