How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeff G. Your Own Question
Jeff G.
Jeff G., Marine Mechanic
Category: Boat
Satisfied Customers: 4723
Experience:  42 years experience, Certified Master Technician, All Major Outboards, Sterndrives, Hi-Performance
27391725
Type Your Boat Question Here...
Jeff G. is online now
A new question is answered every 9 seconds

Tilt and trim works at engine but not at helm. Yamaha 90 hp

Customer Question

Tilt and trim works at engine but not at helm. Yamaha 90 hp 2004
Submitted: 1 year ago.
Category: Boat
Expert:  Jeff G. replied 1 year ago.

Either the harness to the engine from the control is not properly connected, corrosion etc. or the switch itself is bad. If you look under the control you will see the trim harness. With a voltmeter or 12 volt test light you can check for voltage. Voltage on the hot wire, when the up button is pushed you should have voltage on the blue wire too. When the down button is pushed you should have voltage on the green wire. If no voltage on the green or blue but voltage to the switch then the switch is bad. If you do get voltage then check all of the connections under the control, they are bullet connectors and the same back at the engine. Repeat the voltage checks at the engine if the switch checks out fine.

Post back your results and any further questions on this.

Thanks

Related Boat Questions