How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190,
Category: Boat
Satisfied Customers: 25266
14928985
Type Your Boat Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

3604 Cat Generator with a REDCO Protection system that

Customer Question

3604 Cat Generator with a REDCO Protection system that controls Over-Speed, High Temp, and Low oil pressure. The engine shuts down after running for approx. 1.5 hours with the ships load, and will not restart for approximately 20-30 minutes. Could it be my magnetic pick up feeding the control system? As you read this is a marine engine.
Submitted: 1 year ago.
Category: Boat
Customer: replied 1 year ago.
Still awaiting an answer?
Expert:  peterpete190 replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

From what is described here this sounds like an electrical sensor on the engine that is failing or acting up causing this fault here.I have seen sensors that control the ignition components over heat after running an hour or more then need to sit and cool for some time before it will allow the engine to start and run again cause this fault here.If you have not had the ignition components checked into to see if one or more is causing this fault here this needs done.In some cases I have removed electronics from the engine and stuck then in a freezer for about 10 minutes then quickly install them again to see if when one is removed,made cold and reinstalled if it starts right back up then usually that component needs replaced.If this info here isnt of any help let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Boat Questions