How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Boat
Satisfied Customers: 24657
Experience:  17 years automotive training and experience.
14928985
Type Your Boat Question Here...
Pete is online now
A new question is answered every 9 seconds

Have twin 5.7 GXIL H. Starboard side engine is generating a

Customer Question

have twin 5.7 GXIL H. Starboard side engine is generating a beep beep beep continuous sound after 2 minutes of cold start. it started when I hit a ware on my way home. engine kept running and temp and oil pressure were identical between both engines. next morning when i start starboard engine its started beeping again after few minutes (temp was cold, oil pressures was same as of portside engine. I have checked oil levels in Engine and V-Drive and check the anti-freeze levels too. All seems ok;l have no idea which component is causing this alarm. thanks in advance for your help.
Submitted: 1 year ago.
Category: Boat
Customer: replied 1 year ago.
Engines have less than 40 hours on them.
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

If you have not checked for any wiring damage or corrosion on either of the engines I would check and see if any wiring issues are found.In some cases corroded,loose or damaged wiring can cause a fault like this here with the wiring needing repaired to correct this fault.If this has already been checked and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Boat Questions