How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tan Your Own Question
Tan
Tan, MerCruiser Certified Technician
Category: Boat
Satisfied Customers: 10620
Experience:  40 yrs. experience with complete engine repairs both inboard/outboard and MerCruiser Certified Technician.
25721800
Type Your Boat Question Here...
Tan is online now
A new question is answered every 9 seconds

Outboard trim indication. The trim works fine, but no

Customer Question

outboard trim indication. The trim works fine, but no indication on gauge. What is the problem?
Submitted: 1 year ago.
Category: Boat
Expert:  Tan replied 1 year ago.

Hello. My name is Tan.

Could I get the engine serial number please?

Most likely the trim sender has failed or you have a wiring issue to the gauge.

Does the gauge do anything when you turn the key switch on?

Have you checked the wiring and voltage to the gauge?

Expert:  Tan replied 1 year ago.

Check for voltage and ground to the gauge key on. If you have both then the sending unit on the engine is bad and must be replaced. These are the only components in the trim circuit gauge and sender. 9 times out of 10 the sending unit is bad.

Post back with questions and findings.

Related Boat Questions