How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jason Your Own Question
Jason
Jason, Marine Mechanic
Category: Boat
Satisfied Customers: 14305
Experience:  Degree in Marine Technology. Gas and diesel marine mechanic.
44667847
Type Your Boat Question Here...
Jason is online now
A new question is answered every 9 seconds

Volvo Penta 5.7 GXi-N Crank but won't start I changed a

Customer Question

Volvo Penta 5.7 GXi-N Crank but won't start
I changed a blocked riser causing an ECM overheat error on my VP engine and since then the engine cranks and doesn't start, it has however started intermittently but now nothing. Things I have tested:
-Voltage at primary ignition coil and module OK
-Sparks using Diacom spark test
-Both fuel pumps run on Diacom relay test
-Kill & Neutral switches operate normally
-Compression test on changed riser OK (175 175 185 175, no reason to suspect any damage to starboard side
I have ordered a replacement coil / module as my next step as I cannot test these.
two questions,
1. any other ideas?
2. whats the normal operation of the injection drivers, I can see the driver off 10v voltage when cranking, but 0v on the driver on when ignition on. Should this be 12v when ignition on but not cranking / running?
I can only think i've knocked something electrical while clambering around the engine bay fixing the riser as it doesn't look mechanical.
Diacom logs
http://www.executiveit.co.uk/stopped.png
http://www.executiveit.co.uk/cranking.png
http://www.executiveit.co.uk/running.png
http://www.executiveit.co.uk/Injectors.png (ignition / cranking)
Submitted: 1 year ago.
Category: Boat
Customer: replied 1 year ago.
I believe the crank sensor is ok because if I disconnect it throws an error at the ECU, cam sensor registers 0 deg signal.
Expert:  Jason replied 1 year ago.

Good morning, my name is ***** ***** am I speaking with?

I have Diacom as well. Can you send me a copy of a live data recording, I'll have a look at it.

Customer: replied 1 year ago.
Hi Jason Andy is my name how can I send to you?
Expert:  Jason replied 1 year ago.

Hi Andy. You should see a button on the computer screen that says "add files". Click that and select the file.

Customer: replied 1 year ago.
I have added a log from when it cranked over for 5s and started in Sept and some from yesterday od the cranking and not starting and injector logs.I'm based in Hong Kong btw so 6.30am here.Thanks
Andy
Expert:  Jason replied 1 year ago.

Got the recordings. Have you checked the basics yet. That would be checking compression, fuel pressure, spark output, and seeing if it will hit on any starting fluid?

Customer: replied 1 year ago.
Jason as above in my OP
Customer: replied 1 year ago.
Can't find any starting fluid in HK, tried everywhere. But I can smell fuel on cranking and when I had the riser off and it was firing I could see fuel most coming out of the exhaust manifold so I don't think it's fuel. Both pumps running and injectors firing as per the diacom log
Customer: replied 1 year ago.
Voltage at primary ignition coil and module OK
-Sparks using Diacom spark test
-Both fuel pumps run on Diacom relay test
-Kill & Neutral switches operate normally (disabled ignition out of neutral no crank, kill switch cranks but no ignition)
-Compression test on changed riser OK (175 175 185 175, no reason to suspect any damage to starboard side as nothing has changed)
-Injectors show 0v on, which is normal? And off voltage when firing
-Don't see any errors on CMP / CKP sensors on DiacomI have ordered a replacement coil / module as I cannot test the coil or can I check the resistance?Thanks Andy
Expert:  Jason replied 1 year ago.

Do you have a DVOM to check for 12V at the injectors?

Customer: replied 1 year ago.
I will test at the weekend or wait until coil/module is here next week and do both at the same time.
Expert:  Jason replied 1 year ago.

Okay do that. Also check for spark with a timing light, and if it does show spark, see if it will hit on starting fluid and let me know what happens.

Customer: replied 1 year ago.
Coil and module arrived within 4 days! Changed it and fired straight up...Thanks for your help Jason but looks like POE solved it for me and I learnt allot about my engine haha
Expert:  Jason replied 1 year ago.

Glad to hear you got it!

Happy boating,

Jason

Expert:  Jason replied 1 year ago.

Hello, I noticed no rating has been put through. The website has charged you but they will not credit me for helping you out until that rating is complete. Did you have any further questions on the issue?

Thanks,
Jason

Related Boat Questions