How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Charles Your Own Question
Charles
Charles, Marine Mechanic
Category: Boat
Satisfied Customers: 3386
Experience:  US Navy (Ret) Certified Mercury Marine Tech with over a decade of repair experience.
67216606
Type Your Boat Question Here...
Charles is online now
A new question is answered every 9 seconds

I have a 50hp 2004 merc efi that keeps blowing the main 20a

Customer Question

I have a 50hp 2004 merc efi that keeps blowing the main 20a fuse.
Submitted: 1 year ago.
Category: Boat
Customer: replied 1 year ago.
Fuse blows when ignition turns to start position. Starter doesn't engage at all. Fuse just blows.Took apart the control box. Everything looks okay. Disconnect the starter engine and the fuse still blows, so I don't think short is in the starter.When the wire (yellow with red stripe) that I think triggers the starter solenoid is disconnect, fuse doesn't blow, but starter obviously doesn't engage.
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Charles replied 1 year ago.

Hello, my name is***** will assist you today. I have a few questions back for you.

Have you recently done any work with the batteries?

Have you recently hooked up a battery charger?

Related Boat Questions