How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jason Your Own Question
Jason
Jason, Marine Mechanic
Category: Boat
Satisfied Customers: 14299
Experience:  Degree in Marine Technology. Gas and diesel marine mechanic.
44667847
Type Your Boat Question Here...
Jason is online now
A new question is answered every 9 seconds

I have twin mercs 502 mpi that were recently overhauled.

Customer Question

I have twin mercs 502 mpi that were recently overhauled. When I got the boat back and ran it a couple times on the last trip my motor came off plane and now I only have 4 injectors firing. Mechanic states he has done compression tests and has exhausted every avenue.
Submitted: 1 year ago.
Category: Boat
Expert:  Jason replied 1 year ago.

Hello my name is ***** ***** am I speaking with?

If a bank of cylinders is not firing it can only be 3 possiblites. Bad ECM, which you ruled out. Bad wiring harness/short in the harness. Or the ECM is being put into protection mode because of a problem or faulty sensor.

Does the engine alarm system work on the engine? Does it beep every time you start it? Has a Diagnostic scan tool been hooked up to the engine?

Customer: replied 1 year ago.
The engine does beep, the mechanic stated that he did hook up to a computer however he gave up on the problem and kept the boat 7 weeks. The oil pressure on this motor is bouncing between 70 and 80 and the other motor is normal around 40.
Expert:  Jason replied 1 year ago.

70 to 80 is a little high, but it would not cause a bank of cylinders not to fire.

When you break the EFI system down to it's basic components it is a simple system. Think of an injector as a light bulb with 2 wires. 1 wire is positive, the other wire is negative. The injectors always have power to them, all of the time. The ECM applies ground to complete the circuit, and shut the ECM on and off. So what is done to test for a bad harness is you check for power first at the injector (and they will have it as all 8 share a common power wire, so if one was out they would all be out). And then after that use an oscilloscope or even a test light and check the injector ground wire right at the ECM. If it shows a ground signal at the ECM, but not at the injector, the harness has a break in it. If there is no ground signal at the ECM, the ECM is either bad, or it is stuck in "limp" mode. And that would need to be figured out next.

From a mechanics standpoint it's not to hard to figure out. Does that all make sense?

Customer: replied 1 year ago.
I'm going to check the ground wire now to the ECM
Expert:  Jason replied 1 year ago.

Are you working on this yourself?

Expert:  Jason replied 1 year ago.

I am here waiting on you, did you have any further questions on the issue?

Customer: replied 1 year ago.
Something has changed, yesterday the motor started but ran poorly and today I have no fire from the coil on the pink wire. The ignition also does not beep and will not start no
Customer: replied 1 year ago.
I am doing this myself
Expert:  Jason replied 1 year ago.

If you have no fire now next step would be to hook up a diagnostic laptop to the ECM and check the parameters on the live data, or see if it will even communicate. IS that something you can do and then write down and transcribe to me?

Customer: replied 1 year ago.
I do not have a computer and would like to purchase one if you have a recommendation I will order one tonight and try to see if I can get this resolved soon. I have not had this boat operating for a long time and want to get to the bottom of this issue.
Expert:  Jason replied 1 year ago.

I use Rinda Diacom, and It works very well. Click this link, this is the one. http://www.rinda.com/marine/diacommarine.htm

What you want to keep in mind is even with the Diacom, you have to know how to read it and what all of the numbers mean. It won't just say "fix this".

Customer: replied 1 year ago.
Understood, I will order one and if you don't mind I will get a good reading and get back with you for additional help.
Expert:  Jason replied 1 year ago.

Of course, that is no problem, you can reply back at any time, even after doing a rating. I have Diacom as well so you can make a live recording of the data and send the file to me to read.

Jason

Customer: replied 1 year ago.
Purchased scan tool from site you recommended here are results:Starboard (first #is before run 2nd is after starting)
TPS VOLTS: .68vdc / .94
MAT VOLTS: 4.84vdc / .27
Manifold pressure: 29.4 inhg/17.8
BARO VOLTS: 4.86 vdc/4.78
Battery volts: 13.3 vdc / 12.4
IAC POS. 135# ***** 150
Base IAC pos: 115# ***** 121
Iac follower: 0 /11
Inj pulse width: 11.4.ms / 3.75
Inj outime crnk: 11.6 ms / 11.6
Fuel rate: 0 / 3.18
Memgal checksum: 9352 hex / 9352
Fault switch ok
Eng over temp ok
Power reduction off
E stop input off
Spark advance: 6.7/7.7
Knock retard 0.0 / 0.0
Expert:  Jason replied 1 year ago.

Did you buy the diacom or did you buy the techmate?

Customer: replied 1 year ago.
Techmate

Related Boat Questions