How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

Haiving with my 5.7 gxi not starting

Customer Question

haiving with my 5.7 gxi not starting
Submitted: 1 year ago.
Category: Boat
Expert:  Jason replied 1 year ago.
Hello my name is ***** ***** am I speaking with?
GXI engines are fairly high tech engines, and require a bit of tooling to diagnose. That being said I don't know what you have for tools, ability or knowledge. What kinds of questions did you have, or where did you want to start?
Customer: replied 1 year ago.
Hi Jason my name is ***** ***** a tech mate code scanner and pretty knowledgeable, New plugs, wires and new coil, New water pump , New fuel pump
Expert:  Jason replied 1 year ago.
Hi Alan,
Have you covered the basics yet, checking compression, fuel pressure, and especially spark output?
Will it attempt to start on starting fluid?
What is the history/story with the engine, when did it last start, and how old is the gas?
Expert:  Jason replied 1 year ago.
I tried accepting your request for phone service and it says the payment failed.
Customer: replied 1 year ago.
I will pay more with a bonus here is my XXXXXXXXXXXX
Customer: replied 1 year ago.
compression is 175 to 180 all cylinders , it has a new coil and shows spark , the code scanner is throwing no codes, the spark plugs are dry
Customer: replied 1 year ago.
how do I use starting fluid with injectors
Expert:  Jason replied 1 year ago.
I can't call you unless the payments work through first. I don't actually work for the website, so I have nothing to do with billing. What you can do is email customer service at***@******.***, get the billing issue worked out. And once that is done we can proceed with the phone service.
Other that that we can continue online.
Customer: replied 1 year ago.
the gas is from a 2 gallon gas can , the engine has closed cooling
Expert:  Jason replied 1 year ago.
Got it. On the starting fluid you would simply remove the spark arrestor on the throttle body and spray it in the throttle body while a helper cranks the engine over.
Did you check for spark output either with a timing light or adjustable gap spark tester?
Customer: replied 1 year ago.
I pulled the plug and had my son crank the engine while held the plug to a ground and watched it spark and there was spark, even though its multi port injection I can still use starting fluid down the throttle body
Expert:  Jason replied 1 year ago.
Grounding a plug isn't the best way to test it as the plug would show spark if the engine had weak spark. but it won't actually have enough spark to run. The best way to test spark output is with an adjustable gap spark tester. The 2nd best way is with a timing light hooked up to a plug wire. Any other way except for the 2 would be just a guess, and does not confirm anything really.
On the starting fluid just spray it in to the throttle body and have a helper turn the key. See if you can keep it running on the starting fluid by giving it a good shot every other second or so .
Customer: replied 1 year ago.
with the new coil installed could it still have a problem sparking, and I will do the timing light now and check
Customer: replied 1 year ago.
ok starting fluid didn't work , I actually had a little fire for a brief minute
Expert:  Jason replied 1 year ago.
If there are bad plug wires or a bad cap and rotor it won't fire correctly, and spark will be weak, inconsistent, or it will fire on the wrong cylinders. Hook up a timing light to the #1 plug wire and crank the engine over Does the light consistently flash with engine rpms?
Customer: replied 1 year ago.
Ok I did the timing light and I had have a spark can't tell if its strong spark, it has a new distributor cap, if the distributor was in wrong it would hiccup bad correct, it's not even trying to fire spark plugs are dry
Expert:  Jason replied 1 year ago.
Okay you said you had a techmate. Hook it up and turn the key to run to power up the engine and ECM. In the techmate go into live date. Write down every parameter and what the values actually are, and then type them out here and let me know what you get.
Customer: replied 1 year ago.
idle speed 662 rpm , iac pos 87, iac follower 0, bar pressure 29.8, map volts 4.11 vdc, manifold pressure 29.8 hg
.tps volts 62,, throttle pos 0, etc pedal volts 0,,coolant temp 96,, man air temp 100,, injection ontime 14.6,, injection B ontime 14.6,, fuel flow 0 gph,,bat volts 13,,spark advance 20 deg,,cam retard 0 deg,, knock retard 0 deg,,eng knock No,, eng type id 31
ecm check sum 5bde hex,, diagnostic input off,,input j1-20 off,,warning buzzer off,,fuel pump outlet off,,check eng lamp on,,check gauge lamp off,,input J1-21 off,,estop input off,,slave input off,, oil level lamp off,,low oil input off,,rev limiter off,, eng over temp off,,power reduction off,, low oil pressure problem
Expert:  Jason replied 1 year ago.
Hmmm.... The idle speed shows as 662 rpms with the engine not running?
Customer: replied 1 year ago.
checked kill switch and that's fine , the plugs are dry , for some reason it acts like the ecm is not tell the injectors to spray
Expert:  Jason replied 1 year ago.
are the idle speed showing as 662 rpms with the engine off?
Customer: replied 1 year ago.
that is what the techmate is saying , could that because of the engine cranking while trying to start it
Customer: replied 1 year ago.
if the plugs are dry and its turning over and the timing light shows and I have compression what would be telling the ecm not to spray the injectors, the engine turns over like there is a kill switch or something not letting it start and get fuel
Expert:  Jason replied 1 year ago.
Did you take that reading with the key on and engine off? Or did you take that reading with the engine cranking over?
Customer: replied 1 year ago.
that reading was with the key on and me trying to crank the engine, the first time I hooked up the techmate it through up a code about the distributor in backwards, since then I have it in correct and then I reset the codes, no codes come up just the readings I gave u
Expert:  Jason replied 1 year ago.
If you just do a Key on no crank, do the rpms drop to zero?
Customer: replied 1 year ago.
Jason I just hooked up the tech mate and the rpms are at 0 with no codes
Expert:  Jason replied 1 year ago.
Good morning,
I'm not sure what we are doing. I took a look through the history and it looks like you are also working with Michael, and you are doing phone service with him. On that note I will opt out. Good luck!

Related Boat Questions