How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

I have a erratic TPS problem on a 2013 Yamaha F115AET. You

Customer Question

I have a erratic TPS problem on a 2013 Yamaha F115AET. You guys have any experience with this problem?
Submitted: 1 year ago.
Category: Boat
Expert:  Jason replied 1 year ago.
Hello my name is ***** ***** am I speaking with? What kind of fault are you having exactly. Are you getting a code? What is the engine doing or not doing?
Customer: replied 1 year ago.
Yes I am getting the TPS Sensor and sometimes the Air press sensor fault.
Customer: replied 1 year ago.
Also, when I try and do any of the YDIS tests active or stationary it says I'm not in Neutral.
Expert:  Jason replied 1 year ago.
With the key on and engine off what is the air pressure sensor reading for a value?
Customer: replied 1 year ago.
When I can reset the Fault codes I'm able to do the Tests. What is the commonality of the Sensors and the Shift Postion switch. I have tried a New Air Press sensor, TPS and ECU same results.
Expert:  Jason replied 1 year ago.
The ECM is the only common item.
Expert:  Jason replied 1 year ago.
Here is another question... When the ECM says you are not in neutral does the shift position switch show continuity or an open circuit?
Customer: replied 1 year ago.
I removed the Switch today, it has good continuity. I jumped the switch, I checked continuity and voltage at the switch. I have 5 volts closed and 0 open.
Customer: replied 1 year ago.
I forgot to mention sometimes like magic...lol The engine will start and run correctly, No Check Engine or Faults. When that happens all is good.. I can test drive it turn it on and off several times works great. When it's working right, If I turn it off about 5 minutes and back on the same problem. TPS sometimes - Not always the air sensor....usually the air sensor will clear but not the TPS.
Expert:  Jason replied 1 year ago.
You might have a bad harness here. And we can spend hours together going round and round and get nowhere. I'm going to opt out of this one. Good luck with your engine.

Related Boat Questions