How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask TIMOTO Your Own Question
TIMOTO
TIMOTO, Mechanic
Category: Boat
Satisfied Customers: 1444
Experience:  Former Kawasaki pwc tech. current Honda pwc tech.
8313095
Type Your Boat Question Here...
TIMOTO is online now
A new question is answered every 9 seconds

I have a 2002 aquatrax fx12 that I just put a new computer

Customer Question

I have a 2002 aquatrax fx12 that I just put a new computer in. It starts right up now but as soon as I start it up it starts beeping and flashing a FI light. After it runs for aproxamently 30 seconds the temperature light starts flashing. As soon as that
starts flashing I shut it down because I am afraid of damaging the motor. I noticed that after running it in the water for a few minutes and then pulling it out of the water and starting it that no water shoots out. I thought that this ski sacked up water
to cool the motor? I need to know what to do to check this or to clear the codes now that there is a new PGM-FI unit in it. Please help. I want to get this thing in the water.
Submitted: 1 year ago.
Category: Boat
Expert:  TIMOTO replied 1 year ago.
You have two separate problems. I will address the cooling system problem first. Attach a flush hose to the cooling system fit to left of the jet pump. Start the engine and then turn on the water.This should flush he cooling system and you should have water shooting out of the small bypass hole at the rear of the hull and water should pour out of the exhaust outlet above the jet pump. Is that working as described?
Customer: replied 1 year ago.
Do I have to buy some kind of attachment to connect a hose to the ski???
Expert:  TIMOTO replied 1 year ago.
You can buy a premade fitting from your Honda dealer or just cut the threaded fitting off the end of a garden hose and slip it onto the hull fitting securing it with a hose clamp.
Customer: replied 1 year ago.
Ok I did that and it is coming out the little black thing in the back of the ski
Customer: replied 1 year ago.
(###) ###-####
Customer: replied 1 year ago.
Ok so I hooked up the hose and everything did as you said it would. Coolent light still flashed and beeper and Fi light still on
Expert:  TIMOTO replied 1 year ago.
Is water also coming out from the exhaust above the jet pump?
Customer: replied 1 year ago.
I believe so. It is coming out of the hole in the back and also running out the bottom where the propeller is. I was able to get the temperature light off and it is running but it immediately cuts out once it hits 3000 rpms.
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  TIMOTO replied 1 year ago.
Sorry I do not do live phone calls.It sounds like there may have been a restriction somewhere in the cooling system and running it on the flush hose cleared it. The engine control unit ECU will limit the engine speed 3,000 rpm if it detects sensors that are out of range to prevent engine damage. You will need to extract the codes from the ECU to determine what sensor or sensors are out of range. To do this:1 Locate the diagnostic wires link at the right front top of the engine on the main wire harness with the red cap covering it and wrapped in electrical tape. Remove the cap and make a jumper wire to connect the two wires.2 Install the jumper wire, insert the lanyard while holding down the set and mode buttons on the dash. The warning light will start to flash a code of long and short blinks. There may be more than one code. Count the number of long and short blinks and let me know what you get
Customer: replied 1 year ago.
9 it beeps and blinks 9 times and then stops and then repeats
Expert:  TIMOTO replied 1 year ago.
Code 9 is for the intake air temperature sensor circuit. It could be a bad sensor, a poor wire connector or a bad ecu. This failure will cause the ecu to limit engine rpm to 3,000.
First check the wire connectors to the sensor and to the ecu. I have seen a few cases of a bad harness the would cause the problem to come and go when the ecu was removed and the wire harness twisted.
If that checks good then try replacing the sensor. Usually this is not the problem but that is the only way to eliminate that possibility.
If that doesn't fix it then it is most likely the ecu. Usually when it goes out it will give a code for the knock sensor or the throttle position sensor or multiple codes. The only way to eliminate that possibility is to replace it with a known good unit. Since this part is very expensive the best thing to do is find someone locally the has one of these that is running properly and install your ecu on their watercraft and see if the problem transfers. That way you have confirmed the source of the problem.

Related Boat Questions