How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dominick Your Own Question
Dominick
Dominick, Marine Mechanic
Category: Boat
Satisfied Customers: 1009
Experience:  25 Years Experience as Mechanic, 20 Yrs Boat Yard Owner/Mechanic, Factory Certified
14379177
Type Your Boat Question Here...
Dominick is online now
A new question is answered every 9 seconds

Verado 300 engine. New boat 20 hours maybe. Got stuck today

Customer Question

Verado 300 engine. New boat 20 hours maybe. Got stuck today When trying to change from forward to neutral, etc. an alarm went off. Engage would not engage and SR gauges had an error "engine performance ltd"
Submitted: 1 year ago.
Category: Boat
Expert:  Jason replied 1 year ago.
Hello my name is ***** ***** am I speaking with?
Were the gauges flashing a code? Did you hit the up and down arrows to try to pull a code or message out of the display?
Customer: replied 1 year ago.
The display just said engine performance limited and lights were plashing on the tach by the 5,000 and 7,000 numbers. We were tryng to dock and were conconcerned about hitting other boats
Customer: replied 1 year ago.
what should I look for?
Expert:  Jason replied 1 year ago.
What do you have for a display, do you have a Smartcraft tach with the LCD window below it, or a full screen type display?
Customer: replied 1 year ago.
SC tach with LCD below
Expert:  Jason replied 1 year ago.
You have the up and down arrows. What you want to do is start the engine up and wait for it to flash, and then hit the up and down buttons and you should get some more information. Are you near the boat now to do this?
Customer: replied 1 year ago.
yes i can
Expert:  Jason replied 1 year ago.
Okay let me know what you get.
Customer: replied 1 year ago.
sorry not going to work. When I start the engine it is ok, then switch to gear, it is a hard clunk then the tach races up to 7K. I put it in neutral and still races. Had to shut the engine off.
Expert:  Jason replied 1 year ago.
Sounds like you have a DTS failure. You are going to have to take it in. Good luck!
Customer: replied 1 year ago.
what is dts?
Expert:  Charles replied 1 year ago.
Hello, my name is ***** ***** you still require assistance?

Related Boat Questions